Symptoms:
- I cannot afford my subscription for a few months.
- I want to continue my subscription at a later date.
- I want to put my subscription on hold.
- I want to pause my subscription.
Cause:
You may have run into financial difficulty and cannot afford your subscription for a few months.
The specific project you were working on may have stopped and you need to put the subscription on hold until you find your next work.
Resolution:
At this time, subscriptions cannot be put on hold. Once entered into the subscription contract, subscriptions cannot be cancelled until the initial 12 month commitment period has been fulfilled.
Subscriptions purchased prior to June 1, 2020 which have exceeded this 12 month commitment will automatically renew to a month by month contract (flex) which can be cancelled at any time.
These 'flex' subscriptions also cannot be paused. In this instance, you can cancel the license and re-subscribe at a later date.
Subscriptions purchased after June 1, 2020, will automatically renew in accordance with your original payment frequency and commitment period.
More Information:
If you do not want your subscription to renew, you can set the auto renew to Off by following the instructions in the article How do I cancel my subscription.
Comments
5 comments
We are using Unity Pro from three years. But for now we have no projects made using unity. Can we stop/ pause the subscription and restart after few months?
How we will be charged later? We can take monthly subscription or again we have to start from beginning taking 12 month commitment period.
Hi Jung Lee,
Unfortunately, it is not possible to pause or put a subscription on hold.
If you decide to cancel your monthly subscription and then later want to start subscribing again, you will need to begin a new 12 month commitment period.
Sorry that this wasn't the answer you were looking for! I hope that you are able to find a way to move forward, that works for you!
Apparently this changed or there a major contradiction between this and the Unity Dashboard for some reason. The Unity Dashboard (https://id.unity.com/) is telling me this, verbatim. what's the deal? :
Are you sure you want to disable your auto-renewal
Lily - Maybe you can shed some light on this apparent contradiction? Thank you. <3
Hi Landon. Thanks for flagging this with me!
In some circumstances, it is possible to pause subscriptions that are within their commitment period.
If this is something you are interested in, please follow the link on your ID page and our Success Team will be open to discussing your options with you!
In the meantime, I will archive this article, as we get it updated!
Thanks!
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