Symptoms:
- I am attempting to log into my new Unity Account but receive a ''Please check your inbox for a confirmation email'' message.
- I'm trying to create a Unity account, but I've not received my confirmation email.
Cause:
Not receiving your confirmation email can sometimes occur due to one or more of these factors:
- A confirmation email has been sent to the spam folder instead of your inbox.
- You have signed up with a different email address.
- The email address was not spelled correctly.
- A confirmation email has not been sent immediately from our mailing server.
- The system has not completed registration, and you will need to reattempt to sign up with the same email address.
Resolution:
If you cannot see your confirmation email, this could be for several reasons relating to your email account's inbox. There are several likely causes to investigate. These include email quota issues, your DNS settings, and your email client settings.
Make sure that all '@unity3d.com' email addresses have been safelisted. This tells your email client that you know this sender and trust them.
Also, check your spam folders and junk mail. It isn't uncommon for emails to be forwarded to these folders instead of your inbox folder.
Failing that, you can request your confirmation email be resent by clicking on the Re-send confirmation email? button and enter the email address you created your Unity account with.
Ensure you enter the email address correctly, and your confirmation email will be resent to your inbox folder.
Please note: The system can get quite busy, so if you do not receive your confirmation email immediately, you may need to wait a short time for it to be processed. |
More Information:
If you experience problems confirming your Unity account that are not described above, contact Customer Experience. Please make sure to include the email address or username you signed up with.
Comments
11 comments
cannot receive email after 30m,WTF!!!!
Hi there,
Sorry to hear that you did not your email. I can see that you contacted our Customer Service team, however, and they were able to resend this to you! :)
I'm not receiving my verification email for when i change my password, are the mail servers down or what?
edit: i managed to get it but now the link keeps on saying that it cant change my password from there and that I've either already changed it or i should try logging in, i cant login without my password and i haven't already changed it
Hi Shibe,
I can see that your password reset emails are being successfully sent to to the email address that manages your Unity account.
Please make sure that you check your junk and spam inboxes, but if you are still having problems, do feel free to open a support ticket with us!
Hey, can you send a confirmation email to my other account daryhvader6050@gmail.com? I want to delete it because I mistyped the email and I want to use its username but I can't activate it. I've been waiting like 12 hours and I still haven't received it.
How many days does it usually take for support? I had to create a new email for a education license account, but things happend and now I still have to receive the confirmation mail.
Thanks :)
approximately 48 hours :) - Thanks again, great service!
A related problem: if you use outlook.com for your email, the safe links security feature (on by default) will corrupt the hyperlink sent by Unity to confirm your email. Workaround is to log in outlook.com, go to premium/security and disable the link protection feature, and reenable after you get a new email from Unity. This worked like a charm after several unsuccessful attempts at clicking on confirmation emails from Unity.
Hello Phazejump.
I'm sorry to hear you made a mistake in making your email.
Can you please reach out to support@unity3d.com we will ask you some security questions to confirm ownership of the account. Once we have done this we can change the email address linked to the account for you.
All the best.
Hi Perez.
Thanks for reaching out to us. The confirmation typically should be very quick but a slow it down.
I'm glad to hear you received your confirmation.
All the best.
Hi Bruno.
Thanks for the tip.
I'll keep this in our notes for future reference. All the best :)
Derek.
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