Symptoms
- I want to reactivate my license.
- I am receiving this error: "SSl peer certificate or SSH remote key was not OK"
Cause
This is usually due to a connectivity issue between your machine and our license servers. It can be resolved either by adjusting some of your settings, or by performing a Manual Activation.
Resolution
The reason you are not getting the right SSL certificate or SSH remote key is due to one of the following issues:
- You have a firewall or proxy in place which is interrupting your connection to the license server. Please try allowing these ports in your settings: 80 and 443.
- You have an anti-viral software that is blocking the connection. Please try disabling this and seeing if the Editor will work.
- You have a weak or intermittent Internet connection - this is less likely than the points above.
- Unity 4.x no longer allows Online Activation as of September 2018. Performing a manual activation is the best workaround for this if you wish to continue using Unity 4.x
More Information
If this does not solve the problem you may need to perform a Manual Activation.
To perform a Manual Activation:
- Temporarily switch off your Internet
- Run Unity and you will be prompted to initiate the Manual Activation process.
- Follow the steps shown in this document.
Comments
16 comments
None of this worked for me, i disconnected the internet and just got stuck on it trying to load the activation screen.
None of this works for me too.
Obviously, you've got some problems on your servers, fix it!
None of this works for me too.
it doesnt work for me either!
It's seems to me that guys from "Unity" don't bother themselves to read comments to these articles!
Hey! Your product did not work properly, just do something about it already!!!!!
Yeah, my Unity 4 Pro won't activate any longer because it wants to connect to a server that is not reachable. It was already activated previously, so it shouldn't have its license expiring. Lame.
Found on internet...
1. Disable your network interface and open Unity
2. Select 'Manual Activation'
3. 'Save License' to your desktop
4. Re-enable your network interface
5. Go to https://license.unity3d.com/manual and upload the license file
6. The site will download another license file
7. 'Load License' and select this new license file
Worked 4 me :)
yes, technical support responded me yesterday and it seems that it works:
Hi there,
I do apologise for the delay in my reply.
It would appear that a recent change with our license servers has meant that Online activations 4.x are no longer working. Regretfully as 4.x is no longer supported by us, this is something that we cannot fix.
However, as a few users have mentioned above, manual activation is a suitable work around for this.
Sorry once again for any inconvenience caused.
No,.. I tried everything above them. but still not solved. My unity pro license dropped in the trash. suck unity.
Maru said: "Regretfully as 4.x is no longer supported by us"
My rebutal: "Maybe you should support your commercial product we bought or give us a free upgrade to the version that works."
I understand why businesses drop products or even stop supporting them, but this is ridiculous. A major feature is taken away from this version of the product and no workaround/fix has actually been proven to work for 100% of the customer base. Give us something to help us get past this issue, be it a version upgrade license/deal or a bugfix update/patch.
Unity 5 can access the asset store. but unity4 can't... WTF.... hooo...,
Hi there,
I'm sorry to hear that you both are still experiencing issues.
As I have previously advised, no fixes/patches will be deployed to Unity 4.x meaning that we cannot inform of any workarounds going forward.
Unity continues to evolve and amend its internal architecture within the Unity Editor and services it uses. This may mean that some changes would affect with our outdated versions. Unity 4.x was initially released in 2012 and we have come a long way since this release and unfortunately, we cannot continue maintaining these releases where we have to consider our later releases.
If the unity4 is different whole code with other then I agree. but It just developed from old source code. and that's not reasonable explanation of you.
Just say us. We are Greedy honestly.
Legacy support is a very important aspect of software development, so I'm quite disenchanted with Unity right now because of this whole issue with Unity 4 basically becoming unusable, even though it technically still runs just fine. I use Unity 4 Pro, so keep in mind that I paid a lot of money for this version of Unity. It was an investment, and right after I bought it, Unity 5 Free had all Unity 4 Pro's features, so the only reason I had to keep using Unity 4 Pro was the ability to deploy apps without that Unity splash screen. Well, after many years development in Unity 4, I was basically forced to start over because half my assets were no longer in future versions of unity or don't work in them. I'm currently using version 2018.3 for the latest features, but I often open Unity 4 Pro for nostalgic reasons mostly. I would use Unity 4 Pro very often if the asset store still worked for it or the asset store would let me download specific versions of assets directly from the site in Firefox/Chrome. Unfortunately, Unity as a business has chosen to go the route of DRM and not allow this.
For the record, 2012 is not that long ago, either. It's not like we're asking you guys to add new features to Unity 4 Pro. We're just asking for necessary bugfixes to keep previous versions working when things on your end have changed.
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