Symptoms:
- I purchased an asset some time ago.
- I want to download an asset, but it is no longer on the Asset Store.
- I can't find an asset I've purchased.
Cause:
We have a ‘deprecate’ feature for our publishers to use, which means that even if they wish to remove an asset from the store, users that have already purchased will still have access. Unfortunately, assets that were disabled before this feature came in are not accessible to users.
Assets uploaded to our store by publishers later deemed infringing on copyright grounds are removed from our Asset Store. These are no longer available for users to download.
Resolution:
If you downloaded the asset previously:
If you've previously downloaded the asset, it may still be on your machine. Please search for the asset files in these locations:
- Windows: C:\Users\[UserName]\AppData\Roaming\Unity\Asset Store-5.x\[PublisherName]
- Mac: /Users/[UserName]/Library/Unity/Asset Store-5.x/[PublisherName]
Once you have found the .unitypackage, you can drag and drop the folder into your project to import it. You can also right-click on the Editor project window, click Import Package > Custom package, and select the asset you want to import using the file explorer.

If you have not downloaded previously and the asset is deprecated:
If the publisher has deprecated the asset, only users who previously purchased it can download it. As long as you are logged in with the purchasing account, the download should work from the 'My Assets' section of the Asset Store.
If the download does not work, please get in touch with Customer Service with your original invoice number, and they will look into it.
If you have not previously downloaded an asset that has been disabled:
If the asset has been 'disabled,' this means it's no longer available to the users. Please contact support, and they will investigate this further for you.
More Information:
Comments
7 comments
Hey,
It looks as if this was resolved by our Support team! I hope everything is working well for you know.
Please let me know if you have any further problems.
Same problem.
in the message,
If you've already purchased it and need to download a copy, you can do so here.
if click [ here ], just return to [ Home > My Assets ]
What is this?
Same problem as above.
Hello John,
Thank you for your comment. I am sorry to hear that you are having an issue with an asset that has been removed from the store.
Just incase you were not aware, there are actually 2 scenarios in which an asset will be removed from the store.
The first will be if a publisher deprecates the asset, usually meaning that they can no longer provider support or updates going forward. If you have purchased this asset and downloaded it already before it was deprecated, you will always be able to re-download it in Unity again.
The other scenario in which an asset will become unavailable is if it haas been removed by our Asset Store Team due to an issue with its content. If this is the case, the user will see a message simply stating that it is no longer available. In this scenario you will not be able to re-download or access the asset.
I hope this has helped to explain things. If there is anything else you need, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
Actually, deprecated assets that we own are still in My Assets, and can still be searched for and downloaded
Hello Jonathan,
Thank you for your reply. I am sorry if my response above caused some confusion.
Deprecated assets will still show under your account and can be searched for, providing you have purchased and/or downloaded the asset previously. For example, if a new customer tries to access a now deprecated asset, they will be met with a page to explain that it has been removed from the store.
I hope this helps to clarify things. Thanks!
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