Symptoms
- I would like some advice about a purchase
- I would like to purchase a large order
- I would like to purchase more than 3 subscriptions on the same account
Cause
Many purchases can be managed through the Online Store, however sometimes it is easier to go through one of our reps. For example:
- if you wish to purchase more than 3 subscription licenses on the same account
- if you wish to purchase a Premium Support package
- if you wish to purchase vouchers for use on your Asset Store account
- if you belong to a large company
Resolution
Please go to this page to submit a message.
You will then hear back from your region rep.
More Information
Comments
9 comments
Need a phone number to actually talk to a sales person.
Into week 3 attempting to connect with a human being at Unity and have sent countless messages this weekend alone to get some clarity.
We understand Unity is a large entity, At the end of the day I need to address the expectations of my stakeholders and this lack of communication has almost forced our hand to move over to Unreal Engine.
Hopefully I can get some resolutions immediately regarding actual business development.
Wall
Ditto. My legal folks need a name in order to buy licenses. This is now creating a scheduling problem due to lack of responsiveness. I just want to buy your product, and also don't want to have to switch gears to go to your competition, which I absolutely will in about 48 hours.
Hello David,
Thank you for comment and I am sorry to hear that you have experienced some delay in getting set up with Unity.
It seems that someone had reached out to you back in December to request some information from you. However, I have flagged this with my colleagues in our Sales Team, so they will be in touch with you again soon!
If there is anything else you need in the meantime, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
I have no record of having reached out to, or being contacted by Unity in December. We selected Unity as our platform only a few weeks ago. Perhaps it was another contact from my company, which is large.
I will stand by for a sales contact, thanks.
Hii sir
Hello Patrik and David.
If you are still waiting for a contact or have questions about this process, please feel free to reach out to us at support@unity3d.com and we will do our best to direct your query.
All the best.
Derek.
I purchased "That Ball - 2D Arcade Game Template" assets.
Payment is done but I can't get any invoice and I can not use these assets.
So,please help me. Please refund my amount.
Hello Piyush.
Thank you for your comment.
Just to make you aware, the comments section is not the best place to contact us about a refund request. The best thing to do is to contact our team directly via email or by submitting tickets online.
I have taken a look into this and I can see that you have already contacted us, so I will pick up your ticket today and reach out to you shortly to help you with this refund request.
If there is anything else you need in the meantime, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
Please sign in to leave a comment.