Symptoms:
- I misspelled my email address when I signed up.
- My old email address or domain no longer exists.
- I want to change the email address associated to my Unity account.
Cause:
There are different reasons to change the email address associated to your Unity account. For example, you misspelled your email when signing up, the email you initially used belongs to a company or institution you no longer are part of, or perhaps you simply decided to have your account linked to another email address you have.
Resolution:
You can change the email address in your account settings. Please note: the new email address cannot be associated to another Unity account.
To change your email, follow the process below:
- Sign in to your Unity ID.
- Click Edit (pencil icon) on the right side of the email section.
- Enter your account password and click Next.
- Enter your new email address and click Next. You will receive a confirmation email to the new address to complete the process.
After following these steps, your email changes automatically.
If you have lost access to the current email address and you have also forgotten the password or the system is sending a security code to your email, please contact Support.
More Information:
Please see these related articles:
Comments
1 comment
Hi.
I had to update my email to a new one and after the update, althought I can login on site (with the new email), I can't login anymore on Unity itself (neither with old email or new email). When I try to login I get the error "Account is already linked with another external account." How can I fix this?
Thanks in advance.
Please sign in to leave a comment.