Symptoms:
- I have created many different Unity accounts and wish to consolidate them into one.
- An employee has left and I wish to merge their account with another.
- A friend is giving me their account and I wish to merge it with my current Unity account.
- I have purchased Assets on the wrong account
- I want to have all of my Asset purchases on one account
Cause:
Someone in your company may have left and you want their Asset Store purchases transferred from their account to yours.
You may have more than one Unity ID and would like to consolidate all subscriptions and purchases into one account.
Resolution:
It is not possible to merge two ID accounts. If you have multiple Unity ID’s, you can request to delete your unwanted account(s) so you’re left with a single login.
Due to legal restrictions, transferring Asset purchases between accounts is not possible.
If you’re in a company where Assets have been purchased on an employee's account mistakenly, the best way to preserve your purchased Assets is to save the files into a secure shared area, where they can be imported into Projects. To do this, follow the steps below:
- Open the Editor and make sure you are logged in with the purchasing account
- Open the Asset Store window
- Click ‘My Assets’
- Click ‘Download’ next to the Asset you want
Once the download is complete, the Assets' files can be found in these locations:
Windows - User>AppData>Roaming>Unity> Asset Store
Mac - User>Library>Unity>Asset Store
- Drag and drop the Assets' files into a shared area. This might be an area within your secure network, or a Google Drive which only your employees have access to.
- Employees or co-workers can then download the Assets for use in their Projects by dragging and dropping them from the shared area into their open Unity Project.
If someone in your company left and you want to update the email address associated with the Unity ID/Asset Store account to take ownership of it, reach out to Unity Support and provide any evidence to support your request.
Note: The new email address cannot be associated with an existing Unity ID/Asset Store account.
More information:
How Do I Delete My Unity Account?
How Do I Download An Asset I Have Purchased?
How Do I Change The Email Address Attached To My Asset Store Account?
Comments
3 comments
This is a horrible answer. If I purchase 10x assets as an individual and use them then suddenly make more than $100k so I need to upgrade to pro, and so I start a company, I can't directly translate my assets under the new "Organization" within Unity. There's a whole discussion thread around this. https://forum.unity.com/threads/organization-managing-seats-and-purchased-assets.538969/
This needs to be better addressed.
I agree that this is unacceptable. I wound up with two accounts long ago due to issues with Unity's own security. Now, I am entirely unable to access one of the accounts due to bugs in the Unity editor and Package Manager.
My purchases are being held beyond my reach, and the answer seems to be "we choose not to permit this".
Hello Tony,
Thank you for your comment. I am sorry to hear that there has been an issue with your Unity account, I would be happy to help you get this sorted.
Just to put you at ease here, Unity account access is not related or linked to the Editor or the Package Manager, so I am not quite sure what you are referring to there sorry.
If you are experiencing an issue with your Unity account or you are unable to access your Assets, I would highly recommend contacting our Support Team so that we can help you with this. You can either submit a ticket or email us directly at support@unity3d.com.
I hope this helps!
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