Symptoms:
- How do I activate my educational license?
- I have multiple machines that I need to activate my educational license on.
Cause:
Often our educational license holders need to activate on an entire lab of machines at one time. Although this is not yet possible, we now support batch file activation, making things a lot easier.
Resolution:
Here is some background on how educational licenses are activated, as Educational Grant License serials are not activated in the standard way.
At this time, we have no official way of activating licenses on multiple machines simultaneously. However, there is a workaround using the command line.
Activating via Command Line:
Windows: C:\Program Files\Unity\Editor\Unity.exe" -batchmode -username name@example.edu.uk -password XXXXXXXXXXXXX -serial E3-XXXX-XXXX-XXXX-XXXX-XXXX –quit
Mac: Applications/Unity/Unity.app/Contents/MacOS/Unity- quit -batchmode -serial
E3-XXXX-XXXX-XXXX-XXXX-XXXX -username name@example.edu.uk -password
XXXXXXXXXXXXX
We cannot give you the exact commands, as every institute's system is set up differently, however, we can give you some typical commands and you can make changes where you see fit.
See the Unity Manual page for the complete list of command line arguments.
If activating via the command line doesn't work, it may be due to your particular firewalls. Educational firewalls can be tricky to get around with our licenses.
Try allowing these ports in your settings: 80 and 443
As for any firewall which may be running, add the following hostnames:
(IP's may vary):
id.unity.com
api.unity.com
license.unity3d.com
activation.unity3d.com
core.cloud.unity3d.com
sl-http.unity3d.com
developer.cloud.unity3d.com
accounts.unity3d.com
Other than those, there have been reports that the following IP's are contacted (by Google):
74.125.226.222
173.194.43.30
Check your Proxy settings:
HTTPS_proxy=https://proxyusername:proxypassword@proxyaddress.com:8080
UNITY_PROXYSERVER=https://proxyusername:proxypassword@proxyaddress.com:8080
We also recommend checking:
1) Network issue - Some educational users will have an internal network and lack of internet access (can you verify if you can ping to https://core.cloud.unity3d.com/api/login on the command line?).
2) To verify if it is a CACerts.pem issue, can you follow this code:
CACerts.pem is included in the repository.
3) If you can activate from a non-admin account, the activation should work for all non-admin accounts on that machine.
4) If activating on a non-admin account isn't possible, locate the license file after activating it on the admin machine, and save it in a shared area for that machine. This way, if a different user signs in to the device, the license file is shared.
License files (.ULF) are found in the following places:
- Windows: C:\ProgramData\Unity
(If the files are hidden, you must click View and tick the Hidden Items check box.)
- Mac: Library/Application Support/Unity
If the activations still won't go through after toggling your network settings, the workaround is to manually activate the license instead. Guidance for offline (manual) activation is found in the Unity Manual.
Note: Unity can only give you suggestions on the activation process within an educational environment as each campus's firewalls, IPs, etc. can differ dramatically.
Make sure to move the .ULF file into a shared network area for the students to access. If the file stays in the admin area, student logins won't work.
We always recommend creating a generic admin email address and password login for running the Unity install. Once you have done this, the students will be able to log in when needed.
More Information:
Comments
19 comments
Hi,
each year i'm running into the same problems, activating the unity education licenses really is a mess. I'd love an approach like e.g. Autodesk Maya offers: floating licences delivered by a license server behind my firewalls.
Just make things simple :)
Hello
Can someone provide me with the command to do this on a Mac system? The only path you provide is for windows workstations.
I used this PowerShell script to deploy licenses to the machines in my lab (running Windows 7). It is relatively easy and quick. Let we know if you have questions about the process:
$Hostnames = cat $LabConfigDir\TargetMachines\hostnames.txt
$Sessions = New-PSSession $Hostnames
invoke-command -Session $Sessions -ScriptBlock { & "C:\Program Files\Unity\Editor\Unity.exe" -quit -batchmode -serial E3-AAAA-BBBB-CCCC-DDDD -username me@myschool.org -password guess }
If you use this, make sure that the commands don't break across lines - there are only three lines above. You'll also need to have a relatively recent version of PowerShell installed (it seems to be installed by default, but at least on Windows 7 the version needs to be updated - its a free download) and you may need to enable remote execution and allow scripts. You do not need to be logged in to the machines you are installing the license on.
We're experiencing a similar issue as Yvan. When we try to activate 2019.1.5 it returns error level 1, which we believe is that Unity cannot retrieve a valid WinSAT assessment. Again the same command works fine with 2018.
Hello there,
Thank you for your comment. I am sorry to hear that you have been encountering some problems trying to get your Educational Grant Licenses setup. As these licenses work a little differently to our standard licenses purchased and activated online, the process is also a little different.
If you are having issues getting setup, please use this helpful guide, provided by Unity Learn.
Unfortunately, Unity can only offer advice and support up to a point when it comes to activation errors, as each educational institutes network configuration, internal setup and security processes can vary so much, making it hard for us to develop a one-size-fits-all solution, as I hope you can understand.
With that being said we will always do our best to advise and support our customers as best we can.
If there is anything else you need in the meantime, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
I need to activate for all-users on my Mac's and when I run the command line it activates only for the current user, I need a fix please!
Hello Richard,
Thank you for your comment. I am sorry to hear that you are having an issue activating your license. Unfortunately, this kind of thing is nothing something we can troubleshoot or assist with in the comments section, however I can see that you have submitted a ticket with our team, so that is great to see!
I will flag your existing ticket and someone will reach out to you shortly.
If there is anything else you need in the meantime, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
Does anyone use this in a VDI environment?
We use Vmware Horizon and even though I can activate the license on the server the app is installed on, when the user goes to our app portal and runs the app it says the license is not activated.
Hi, my name is Laura Carreon, I want to design a Unity day event at my university, and I wonder how can I get some help from you, in order to have some workshops or lectures. I'm the coordinator of the 3D design and videogame program.
Thank you
Laura Carreón
Universidad Incarnate Word Campus Bajío
Irapuato, Guanajuato, México
How can I tell whether a installation is activated after a network install? We live behind a proxy.
@JCS Unity I noticed the same problem in my lab - but only on the one machine where I was logged in when the script to install the license ran. I was not left logged in to any of the other machines. Once I logged out of my Unity account on that one machine I was not logged in when I relaunched Unity.
I was running into a strange edge case that wasted a bunch of my time and wanted to leave a comment here for anyone who might run into this in the future. I had a % sign in my auto generated password and it turns out that the percent sign is a special case in windows command line that will work just fine at a command prompt but will not run in a saved .bat file. In order for it to run in saved .bat file you will need to type %%.
Found this info after an hour or two of trying to understand what was going on:
The percent sign (%) is a special case. On the command line, it does not need quoting or escaping unless two of them are used to indicate a variable, such as %OS%. But in a batch file, you have to use a double percent sign (%%) to yield a single percent sign (%). Enclosing the percent sign in quotation marks or preceding it with caret does not work. (https://en.wikibooks.org/wiki/Windows_Batch_Scripting)
Could you help please. I have a number of Mac labs that need the license activating. What would be the command line to do this, as the example you give above is only for Windows machines.
This works well but the account used to activate the software is still logged in when the users open the software giving them access to change account settings. How do you log that user out so they can use the software in Offline Mode?
Hi. We seem to be having an issue with using this method with the 2019.2.1 version (not tried other 2019 versions) but it worked with 2018.2. Has anyone got this working with 2019?
The software activates fine and any user can login and use the activated program. The problem I am having is that the admin account used to activate the program is still logged into the program and the students can click manage account and it takes them to the online account management page. I need to know how to sign out the admin account as part of the cmd line activation so the students use the program in "work offline", ie not able to access the Asset Store. I am using the below deployment guide and option 1 on the first page.
https://unity3d.com/sites/default/files/unity-license-deployment.pdf
Hi AIE Software,
Thanks for the detail process you have been using with the Educational License. Hope other users find it useful too.
We wil have this process in mind.
Hi there,
Sorry to hear you are having some issues with your Educational activation.
If you have activated with an admin account, you will need to locate the license file after activating and save it in a shared area for that machine.
This means if a different user signs into the machine, the activation should be there and they will not need to be logged in with the admin account.
License files are found here:
* Windows: C:\ProgramData\Unity
* Mac: Library/Application Support/Unity
Here is how we do it, within a user login script: https://gist.github.com/michaelp85/05ece28e3a959ffda008441774170dac
Pre-reqs:
What the login script does:
If the StopDate value is current, it does nothing.
If it's something else, we blow away the current license and re-license via batch mode.
If the Unity_lic.ulf file doesn't exist at all, we license via batch mode.
We've got thousands of PCs, and so far this is the most reliable licensing mechanism we've found.
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