Symptoms
- I want to cancel my online subscription but I don’t know how many months are left of my 12-month commitment period.
- Does my online subscription have an expiry date?
Causes
New subscription purchases have a 12-month commitment period. During this commitment period, subscriptions must remain active and all installments paid before the subscription can be canceled. You may want to know when your commitment period ends, for example, if you would like to cancel or decrease the number of seats.
Resolution
If you are curious as to how many months are left in your 12-month commitment period, please follow the steps outlined below.
The resolution differs depending on the screen you’re directed to upon purchase. If you clicked Complete onboarding on the final screen when purchasing or your subscription has been migrated to the Unity Dashboard, please click here to jump to your resolution. |
If your subscription is housed under id.unity.com, and you are the organization Owner, please follow the steps below:
- Navigate to id.unity.com and sign in using your account credentials.
- On the left-hand side of the page, click Organizations.
- Click on the organization name containing your subscription.
- In the Subscriptions section, click Manage (cog icon) next to the subscription you want to manage. (Note: If you’re unable to find your subscription listed on this page, it may be managed through the new system. Click here to jump to your resolution.)
- The final date of your commitment period is shown on the right-hand side of the Subscription progress bar. The bar fills up as you progress through your commitment period.
Alternatively, if you still have your original purchasing email and invoice, this also indicates when your 12-month commitment period is due to renew.
If you are still within your commitment period, you are obliged to make the monthly payments until this commitment period has ended. See the Terms and Conditions for details.
I clicked Complete Onboarding during purchase/ My subscription has been migrated to the Unity Dashboard
If your subscription is housed under the Unity Dashboard and you are the organization Owner, please follow the steps below to see how long you have left on your commitment period:
- Navigate to dashboard.unity3d.com and sign in using your Unity ID credentials.
- Using the left-hand menu, click Projects.
- Using the left-hand menu, click Subscriptions.
- Click on the Unity subscription you want to manage.
- The final date of your commitment period is listed on the Overview page.
Please note: Your subscription will automatically renew on this date unless automatic renewal is switched off. |
If you are still within your commitment period, you are obliged to make the monthly payments until this commitment period has ended. See the Terms and Conditions for details.
More Information:
Comments
0 comments
Please sign in to leave a comment.