Symptoms
- I want to cancel my online subscription but I don’t know how many months are left of my 12-month commitment period.
- Does my online subscription have an expiry date?
Causes
New subscription purchases have a 12-month commitment period. During this commitment period, subscriptions must remain active and all installments paid before the subscription can be canceled. You may want to know when your commitment period ends, for example, if you would like to cancel or decrease the number of seats.
Resolution
If you are curious about how many months are left in your 12-month commitment period, follow the steps outlined below.
The resolution differs depending on where your Unity subscription is housed. If your subscription is housed under the Unity ID portal (id.unity.com), click here to jump to your resolution. |
If your subscription is housed under the Unity Cloud Dashboard and you are the organization Owner, follow the steps below to see how long you have left on your commitment period:
- Navigate to cloud.unity.com and sign in using your Unity ID credentials.
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Using the left-hand menu, select Administration > Subscriptions.
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Select the Unity subscription you want to manage. For example, Unity Pro. (Note: If you cannot see your subscription here, it may be housed under the ID portal. Click here to jump to your resolution.)
- The final date of your commitment period is listed on the Overview page.
Note: Your subscription will automatically renew on this date unless automatic renewal is switched off. |
If you are still within your commitment period, you are obligated to make the monthly payments until this commitment period has ended. See the Terms and Conditions for details.
If your subscription is housed under id.unity.com, and you are the organization Owner, follow the below steps:
- Navigate to id.unity.com and sign in using your account credentials.
- On the left-hand side of the page, select Organizations.
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Select the organization name containing your subscription.
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In the Subscriptions section, click Manage (cog icon) next to the subscription you want to manage. (Note: If you cannot find your subscription listed on this page, it may be managed through the Cloud Dashboard. Click here to jump to your resolution.)
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The final date of your commitment period is shown on the right-hand side of the Subscription progress bar. The bar fills up as you progress through your commitment period.
Alternatively, if you still have your original purchasing email and invoice, this also indicates when your 12-month commitment period is due to renew.
If you are still within your commitment period, you are obliged to make the monthly payments until this commitment period has ended. See the Terms and Conditions for details.
More Information: