Symptoms:
- I would like to give a new user access to my Unity Plus, Pro, or Enterprise license.
- I am the Owner or Manager of my Unity Organization.
- I have received the error: "Serial Is Not Assigned To You, Please Contact The Owner Of The Organization".
- My company has purchased a Unity subscription, but I have not received a license key.
Cause:
The ability to use a license is controlled by Seats. This is the system that Unity has used since June 2016. Seats must be assigned to users by the Owner or Manager of their Unity Organization in order for them to activate Unity.
License keys are generated per Unity ID once a user is assigned a seat. As such, one license key will work for the user assigned the seat but will not be valid for use by another Unity ID.
Resolution:
- Sign in to your Unity account on the main site.
- Click 'Organizations' to the left side of the screen.
- Click on the Organization which is linked to the subscription you would like to assign the seats under.
- Click the cog icon to the right of your Unity subscription to manage it.
- On the following page, you will be able to see how many Seats are 'Available/Pending' in that specific Organization. Click the 'Manage Seats' button.
- Under the 'Manage seats' tab you will be able to assign seats to users by clicking the box to the left of the name/ email address and clicking the blue 'Assign seat(s)' button.
Please note: The user will need to be invited to join the Organization by the Owner in order to have a seat assigned. To do this, follow the steps outlined in the article 'How do I invite a new User/Member to my Organization?'. - Each user will then receive an email containing their Unity license key.
More Information:
To make someone a Manager in your Organization, please see the article How do I invite a new User/Member to my Organization?.
A user can bring a Pro Seat of the Editor with them when collaborating on a Project for another Organization, but not the Services as they are tied to the purchasing Organization. That is to say, Services can only be used on Projects owned by their purchasing Organization.
Comments
7 comments
that is true
after hdd crash on my work computer i can not activate subscription again a have removed seat added again and now i am stuck. And i don't want to cancel subscription and then add a new one because i could lose my price i got recently 26 instead of 35. Does anybody know how to reset subscription , or to remove seat assign to another mail and will i lose my price discount ?
Update
I have managed to return license on my home computer, and removed me as user of that license and then I have successfully added license to my work computer. but now i can not use it on my home computer.
Means now only one computer can use license instead two, and still dont know how to release license for other computer since hdd is dead .
Hey! Sorry to hear you have had some issues with your activation's.
All activation's can be returned via the Unity Editor. You can do this by following the below instructions:
As your machine had a crash however, you will need to contact our Support team to reset your license activations for you!
Please email 'support@unity3d.com', stating the name of the machine you would like resetting, and this can be done for you!
I wrote to support with the exact same problem as Арсен Ђури, but no response. Please repair my licence (request 89773), I woul like to continue my work :-).
Thanks :)
Hey Jindrich,
Looking on our systems, it seems that your issue has now been resolved by our Customer Service team! Glad your issue was fixed :)
Hello,
It looks like Unity has managed to set up a "hell of a ride" when it comes to activate one's license! ;)
My problem is a bit similar: I've managed to set up my account settings (Name: By / User: Computed), to assign a seat to myself (Name: Keller / User: ptrckkllr) - I want to assign it to someone else later -, I've received the code to access my Unity seat by email. So far so good.
And then... then nothing happens... (I'm not prompted when I open the editor and if I then try to enter the received code myself in the Help/Manage License section I'm being told that the code is wrong... I did try several times, reassign seat, etc. Same issue)
As a matter of act, as I couldn't achieve that last month when I bought the product, but then had to travel, I lost the access to the Accelerator Pack offer I also bought...
I tried again today, same issue.
...
I have a Unity Plus, one seat.
Could you please help?
Is the reason linked to the fact that I also have a Unity Personal installed (but not activated apparently)?
And as a matter of fact, could you reactivate my Accelerator Pack that I lost at the same time? That would be great!!
Thanks in advance,
Patrick
Hi Patrick, I know this is pretty old but as I've just gone through this same problem and I couldn't find any decent information about how to fix it.
The solution is to go to C:\ProgramData\Unity and delete all the *.ulf files then open Unity again. It will forget about your Personal activation and it will let you activate your Unity Plus or Pro.
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