Symptoms:
- I need to download the invoices for my Unity Pro or Plus subscription.
- I want to download an Asset Store invoice.
- I did not receive the invoice for my subscription.
- I can't download my invoice.
- I see an error when I try to download my invoice.
Cause:
The process for downloading invoices differs depending on the Unity product purchased. You may need extra guidance on finding the appropriate place to download your purchase invoice for accounting purposes, for example.
Unity stores invoices for a maximum of 12 months after generation. Attempting to download an invoice that was generated over 12 months ago will result in an error message being displayed on-screen.
Note: Users within an organization that are assigned manager or user roles cannot view or download invoices. |
Resolution:
The resolution differs depending on the product purchased. Use the links below to jump to your specific resolution: Download a Unity Editor subscription invoice (purchased online) |
Download a Unity Editor subscription invoice (purchased online)
The resolution differs depending on the screen you’re directed to upon purchase. If you clicked Complete onboarding on the final screen when purchasing or your subscription has been migrated to the Unity Dashboard, please click here to jump to your resolution. |
If your subscription is housed under id.unity.com, and you are the organization Owner, please follow the steps below:
- Visit id.unity.com and log into your Unity ID.
- Click Organizations to the left of the screen.
- Click the organization your subscription is associated with.
- Click Transaction History to the left of the screen.
- Click the Purchases tab and download the PDF invoices by clicking Download.
I clicked Complete Onboarding during purchase/ My subscription has been migrated to the Unity Dashboard
If your subscription is housed under the Unity Dashboard and you are the organization Owner, please follow the steps below:
- Navigate to dashboard.unity3d.com and sign in using your Unity ID credentials.
- Using the left-hand menu, click Projects > Transaction history.
- Click the download icon to the right of the invoice you want to download.
More Information:
What can owners, managers, and users do in an Organization?
How do I invite members to my Organization?
Comments
8 comments
Can I receive my invoice every month by email?
Is that an option only for users that purchased their license before June 2016?
Hi Katsunori,
Thanks for the question.
Last year, some changes were made on how invoices from your subscription are received.
These changes were made to tighten our security system in order to protect our users’ information from being exposed by any mistake that we may have in our automated mailing system.
See above article on how to find this on your account for any future invoices you will need to download.
I hope this helps,
Hello,
Im trying to download an invoice but can’t see any files (Transaction History —> purchases). I am the owner of an Organization. Last month (May 2020) I was able to download the invoices.
I have also contacted support, but no response yet.
Additional help is much appreciated
Rick
Hi Rick.
Derek from Unity Customer Service here. Thanks for reaching out to us. I'm sorry for the delayed response. We've been receiving an influx of tickets and are currently working through them as quickly as possible.
I can see your ticket in our queue and we will get to it very shortly. I've also taken a look at your Unity ID linked to the email address which submitted the ticket and cannot see any subscriptions attached.
To better assist you with this, can you please reply to the same ticket thread to inform us which account this is in relation to?
I really appreciate your understanding. All the best.
Hi,
I just tried to download my invoices for 2021 but a lot of the download links return a 404 not found page. I lodged a request as well but was wondering if there is another way to retrieve these.
Thanks,
Volker
Hello Volker,
Thank you for your comment. I am sorry to hear that you are having an issue downloading your old invoices.
The best way to get help with this issue is to contact our Customer Experience Team, so they can look into this for you. Unfortunately, this is not something that can be handled in the comments section, as there may be an issue with your account or a bug of some kind.
Please email us at support@unity3d.com or alternatively, submit a ticket via this web form.
I hope this helps!
Just be aware there is a current error on this now. I am directed to a 404 error page if I try to download an invoice.
Hello Leticia, thank you for your comment!
I am very sorry to hear that you are experiencing an issue downloading your invoice. I can see how this must be causing you some frustration.
I can see that you have already submitted a ticket with our Customer Experience Team, which is the best thing to do in this scenario. Your ticket will be picked up and handled by our team as soon as possible and I am sorry again that you have faced this issue.
If there is anything else you need in the meantime, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
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