Symptoms
- I have submitted a package to the Asset Store and would like to know how long I will have to wait for it to be approved
- I have not heard back from the Asset Store Curation Team about my package submission.
- My package has been pending review for a while.
- I did not receive a confirmation email when I submitted my package for review, is everything okay?
Cause
Once a Publisher has submitted a package to the Asset Store, it is placed into a vetting queue where it is reviewed in turn by a member of the Asset Store Curation Team.
Resolution
This process cannot be sped up, but making sure all parts of the package are working and correct will allow your submission to be reviewed more quickly.
We try to review Assets within 14 business days, though the time can increase or decrease depending on the number of submissions we receive.
If you are updating a package, the process is much faster, but we do ask that you include detailed submission comments when you submit your package.
When your package is submitted for review, you will receive an automated email thanking you for your submission.
If you do not receive this automated email, or your package has been in the ‘Pending’ stage of the review process for longer than 14 days, please contact Customer Service so we can check the status of your package.
When your package has been approved, its status will change to Published on your Publisher Dashboard and it will be live on the Asset Store within one hour!
If your package is not approved, the status of the package will change to Declined on your Publisher Dashboard.
If this is the case, please update your package based on the comments emailed to you and resubmit the package.
More Information:
Asset Store Submission Guidelines
Comments
14 comments
and if it took more than two weeks?
Hi Eugene,
Sometimes, there can be delays with the Asset Store review process. During these times, the review team work as hard as they can to get through the queue as quick as they can!
If your asset review is taking significantly longer than the allotted two weeks, please let our Support team know on 'support@unity3d.com' and they can give you any further information that is available!
For me it always take more than 20 days.
Best case 24 days
worst case upto 40 days.
Is there some sort of priority you assign to package ? Like publisher previous record, ratings or quality of asset ? or even country form where the asset belong ?
More than a month for sure!!!! If you did a mistake you will wait another month so be careful the first time because the tool never check is everything is ok. Just cry and wait for another month :(
I've published a lot of 3D models on the Asset Store and they usually take around 2 weeks ( 10 working days ) to get reviewed and published ( assuming you don't have to make any changes ).
Please make this process more faster... Its too hard and pain to wait. 1 day is critical for indie..
Hi all,
Thank you for your feedbacks! We are always trying our best to speed up the process so as to cater to all your submissions.
If your asset review is taking longer than the allotted two weeks, please let our Support team know at 'support@unity3d.com' and they can give you any further information that is available!
My apologies for the inconvenience caused and thanks for your understanding.
30% share and 14 business days ( nearly three calendar weeks!!! ) to approve an asset simply don't fit together!
Unity Technologies you should do it within a couple of days! Seriously! It's a shame.....
My package is pending review from April and now(December) it still pending.
Agree with Zhang, in some cases this is ridiculous, I have been waiting for 2 months now and nothing yet.
Hello Timo, Zhang and Nick.
Derek from Unity Customer service here.
I'll do my best to address any concerns you may have in regards to your queries.
In terms of the 14 days review time, these are not business days. This is 2 weeks, not 3 business weeks. Typically we review these assets quicker than 14 days and can take longer if an influx of submissions.
The amount of time we give ourselves to review the assets is imperative to maintaining and improving the standard of quality of assets in general on the store.
The amount of time that is listed is to compensate for an influx of submissions.
If it takes longer than this or if you would like to discuss this further, you can always reach out to "support@unity3d.com" to find out the status of the Pending Asset. We can then look into this for you :)
If my Asset was declined due to the incompleteness of my page. I corrected and responded by mail. Need to wait for an answer or re-send an Asset?
14 days have passed. Still pending review.
My asset still pending review althought 22 days pass, waiting in vain...
Please sign in to leave a comment.