Symptoms:
- I see a warning message when launching the Hub.
- I can see a message that says, 'Your current license doesn't comply with the Terms of Use and might be revoked soon. Contact your system administrator or activate a new license'.
Cause:
The warning, 'Your current license doesn't comply with the Terms of Use and might be revoked soon. Contact your system administrator or activate a new license', is shown when Unity believes you may be ineligible to use Unity Personal.
Resolution:
Unity Personal licenses are only available to customers with revenue and/or funding below US $200K for the most recent twelve (12) month period. For more information on tier eligibility, see the Unity Editor Software Terms.
To continue using Unity without interruption, you must purchase a new Unity license that best suits your needs and is compliant with the Unity Terms of Service.
If you believe your account has been warned by mistake, speak with your Unity Client Partner or contact compliance@unity3d.com.
More information: