Symptoms:
- Unable to post a review on a purchased asset.
- When attempting to post a review, an error message stating "Please download this asset to leave a review" appears.
- Reviews cannot be posted from any device.
Cause:
Due to an incorrect Unity ID or ongoing maintenance, you might not be able to submit reviews for purchased assets.
Note: You cannot post reviews for assets you have not purchased. |
Resolution:
Please follow these steps to resolve the issue:
- Access the assetstore.unity.com.
- Log in with the correct Unity ID.
- Check your order history and access the asset to post your review.
Note: If you're logged in with the correct Unity ID but still can't post a review, it might be because you were previously suspended for inappropriate actions. You'll need to wait until the ban is lifted or contact the Customer Experience team for help. |
Furthermore, you may be unable to post reviews if the Asset Store is undergoing maintenance. Check the Service Status or contact Customer Experience team for assistance.
More Information: