This article is intended for users who want to manage their accounts using the legacy Unity ID portal |
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Symptoms:
- I have spelled my username incorrectly.
- I want to change my username on my Discussions profile/ Asset Store using the ID portal.
- My username is outdated, and I want to update it using the legacy ID portal
Cause:
There could be several reasons to change your username in your Unity account. For example, you have just created an account and realized that your username choice was wrong, or perhaps, your name or company name is outdated.
Resolution:
You can modify or change your username yourself, providing that the username has not already been taken by another Unity user.
To change your username, follow the process below:
- Sign in at id.unity.com.
- Click the pencil icon on the right-hand side of the username section.
- Enter your new username and click Save. You will be asked for an alternative username if the one you have entered is already taken by another user.
After completing the above steps, your username will automatically update. If the change does not show immediately on Discussions or The Asset Store, try signing out and back to sync all of the accounts with the same username.
Note: If after signing out and waiting 24 hours your username on Discussions or the Asset Store has not been updated, contact Unity Customer Experience. |
More Information:
How do I change the email address attached to my Unity Account?