Symptoms:
- I need to change my credit card for the Plastic SCM subscription. How can I do that?
- My payment has expired. How can I add a new payment method for the Plastic SCM?
- I cannot update my payment method via Unity Cloud. Where can I update it?
Cause:
If you signed up for Plastic SCM from plasticscm.com before it was rebranded to ‘Unity Version Control’, which is now part of Unity DevOps, you can manage the subscription via Plastic SCM dashboard, not Unity Cloud dashboard.
Your current payment method has either expired, been lost, or you prefer to use a different payment option.
Resolution:
To update the payment method for your Plastic SCM subscription, follow these steps:
- Login to your Plastic SCM Dashboard.
- Click the Edit account menu on the right side.
- Scroll down and you will find the Billing data section.
- You can add or change a credit card in that section by clicking the button and adding the details.
Note: If you signed up for Plastic SCM from unity.com or if you are a Unity DevOps user, please check this article: How do I change the payment method in Unity Cloud?
More information:
Manage Plastic SCM account and subscription