Symptoms:
- My asset is in pending status but my position in the queue has increased.
- Why did my Asset Store Curation queue position go up?
- My package submission exceeds the estimated wait time.
- Why is my pending queue only going up?
Cause:
Positions in the Asset Store submissions queue are not updated in real-time and provide an approximate indication of your asset's place in the overall work queue. These numbers are only a reference.
Resolution:
The Asset Store team reviews all submissions against the Asset Store Submission Guidelines.
The current number representing your position in the review queue is updated daily, reflecting the number of assets pending review ahead of yours at the specified time.
Please note that your position in the queue may also decrease due to the number of currently published assets submitted for updates, as updates are given priority over new submissions.
To help speed up the process, please ensure the following:
- All parts of your package are functioning correctly.
- You have used the Validator tool to scan for errors.
- You have included detailed submission comments.
For current waiting times, please refer to the 'How long will it take for my Asset to be approved?' article.