Symptoms:
- I would like to remove TFA from my account.
- How do I remove SMS 2FA from my account?
- I have a new mobile device and would like to disable my Two-Factor Authentication link with the old device before I add it to my new one.
- I am planning on changing the email address on my account to a new one and I would like to disable my Two-Factor Authentication link with my current email address before I add it to my new one.
Cause:
Users can remove their Two-Factor Authentication (TFA) token at any time via their account page. This is particularly useful if you need to swap mobile devices or change the method by which you would like your code to be received.
Resolution:
Note: If you no longer have access to your previous TFA device, please contact the Customer Experience team. |
- Sign in to your Unity ID.
- Click Security to the left of the screen.
- On the Account Security page, click Edit (pencil icon) to the right of the Two-Factor Authentication header.
- Here, you can see your existing TFA details. To remove these, press either Disable All or Remove (x icon). If you just want to change the phone number or Authenticator App to a new one, click Edit (pencil icon) to the right of your authentication method.
- Once pressed, you'll need to input a TFA code either sent to you via SMS or an authenticator app.
- To confirm the removal of TFA from your account, click Remove in the pop-up box shown.
- An email has now been sent to you to confirm TFA has been disabled.
If you encounter any issues with the above process, or you do not receive an SMS code, please contact the Customer Experience team.
More Information
For guidance on how to add TFA to your account, please refer to the article How do I enable Two-Factor Authentication on my account?
Comments
7 comments
The real problem is it ask for verification code for any changes to security page once your 2FA is enable, and do not to provide a alternative way for sending code. Once it failed in the case like wrong/changed phone number, lost old phone and etc, this will lock the user out their account. Please continue to upgrade Unity 2FA system, it is very useful but only if it is good enough.
I tried these steps, but as mentioned in another post you need a 2FA code in order to remove it from your account.
The problem is I lost my device and am at the moment locked out of my account, I made a support ticket, but it has been open without a single response for about 10 days now.
I should have made a recovery code, it never occurred to me. I actually expected to have a code, in a similar fashion as Steam, which gives you a recovery code the first time you activate 2fA.
Hopefully the system gets some proper recovery steps in the future.
Edit: After several more days I was contacted by Unity support. The problem was solved within a single day! As luck had it, since I was still logged in on my publisher account with an authorized device (my dev pc). I was asked to give the proper credentials and information only visible in my publisher account to manually reset my 2Fa through Unity's support team. After I gave this information This time I made sure to generate recovery codes. Thanks again to the team to solve my issue.
I decided to add this edit because not only the bad things should be shown, the good actions Unity take are just as important.
I logged in to the `security` tab, and have 2 options (phone/authenticator). I clicked 'phone' since I lost my device and can't use the authenticator app.
Still the website takes me to use my authenticator app. It does not care that I clicked on 'phone'. Helpless. Contacted support.
P.S. Leaving a message on this page, I get a 'HTTP ERROR 406'.
EDIT: Cool, it worked the 2nd time.
I lost my phone and I cannot login to Unity Account
how do I should do next?
Hello Michael.
Derek from Unity Customer Service here.
I'm sorry to hear you've lost access to your account. You're correct, this method is for users who still have access to the device which they enable TFA on.
If you no longer have access to your phone or the authenticator app, please reach out to us at support@unity3d.com
We can then remove the TFA from your account allowing you to log in and re/add your device.
Please feel free to get back to me if you have any follow up questions.
All the best.
Derek.
Unity Customer Service.
Rachan Neamprasert
(you can read my edit in a comment above).
In short.
The only option you have, is hoping your are still logged in on a publisher account through your web-browser or somewhere where you still have access to your account.
IF you still have access to a logged-in publisher account on the unity website, you can start taking these steps:
- Contact Unity Support with your 2FA problem, that you lost your authentication device.
They will send you several questions to gather information that only you as owner should be able to see on a logged-in account.
If said information matches, they will probably remove the 2FA for you and you can reset your authentication device.
That said. This is what worked for me. Whether they accept your response is up to their discretion. As soon as you can't answer one of the requests (which you should be able to), it is pretty much game over.
Also, as you can read in my previous comment. Support might take a while or even a few weeks before they finally reach out to you. So patience is key.
Same issue - this method requires you to log into your account to disable Two Factor Auth. However, if you somehow lose access to your auth provider, you have no way of logging in. I had to create a new account.
At least my original account is safe...?
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