Symptoms:
- Where are my Unity log files?
- I have been asked by Unity support to provide an Editor.log file or Hub log file.
- Unity Support requires a log file to investigate my activation error.
- I do not know where the log file is.
Cause:
You are seeing an error whilst attempting to activate Unity and the support team has requested a log file so that they can investigate further.
You are experiencing problems launching the Unity Hub or Editor.
Resolution:
You can find the log files in the directories below. (If the files are hidden, click ‘View’ and tick the ‘Hidden items’ checkbox.)
The Hub log file (info-log.json) can be found here:
- Windows:
C:\users\[yourusername]\AppData\Roaming\UnityHub\logs
- Mac:
~/Library/Application Support/UnityHub/logs
- Linux:
~/.config/UnityHub/logs
Editor.log can be found here:
- Windows:
C:\users\[yourusername]\AppData\Local\Unity\Editor\Editor.log
- Mac:
~/Library/Logs/Unity/Editor.log
- Linux:
/.config/unity3d/Editor.log
Unity.Licensing.Client can be found here:
-
Windows:
C:\users\[yourusername]\AppData\Local\Unity\Unity.Licensing.Client.log
-
Mac:
~/Library/Logs/Unity/Unity.Licensing.Client.log
-
Linux:
~/.config/unity3d/Unity/Unity.Licensing.Client.log
Package Manager log can be found here:
- Windows:
C:\Users\username\AppData\Local\Unity\Editor\upm.log
- Mac:
~/Library/Logs/Unity/upm.log
- Linux:
~/.config/unity3d/upm.log
More Information:
Sometimes, the Hub log cannot be sent due to the error "json not being supported." If this happens, try renaming the file, e.g., adding "info" at the beginning to resolve this.