Symptoms:
- I want to activate my license via the Unity Hub. However, I am receiving errors.
- My serial number/ license key is not activating.
- I see the error message, 'Serial number has reached maximum license activations'.
- I want to access the Unity Editor, but I am receiving errors in the Hub.
Cause:
The most common cause for this error is that the license/ serial key has run out of activations. If you have recently updated your OS or changed any hardware, this can alter the hardware ID to which the Unity License File (.ULF) is attached, effectively making the current .ULF redundant.
Each Unity subscription license can be activated on two machines at any one time.
Resolution:
You can return activations made in Unity Editor versions 4.5 and higher via your account page. To do this, see the article 'How do I return the activations on my Pro/ Plus/ Enterprise license?'.
If releasing your activations & checking your connection still does not help you activate your license, you may be experiencing a conflict with the license file saved on your machine. You need to delete the existing license file and create a new one:
- Close the Hub completely using the task manager or similar.
- Using your file explorer, navigate to;
- Windows:
C:ProgramData/Unity
- Mac:
Library/Application Support/Unity
and delete the .ulf file housed there.
- Windows:
- Relaunch the Hub, making sure you allow the Hub to make changes to your hard drive in the process.
- Reactivate your license following the steps outlined in the article, 'How do I activate my license?
If your license is still not activating after troubleshooting, get in touch with Customer Experience, including your Hub log file in your ticket, so we can look closer at your issue.
More information:
I have been asked to provide a log file, where do I find this?
How do I activate my license?
Manual activation guide
How do I return the activations on my Pro/ Plus/ Enterprise license?