Symptoms:
When I try to perform an update, I got an error message that says “Cannot download revision XXXXXX from server: data XXXXXX is encrypted. The encryption info is needed in order to read it.”
I don’t have encryption enabled.
Cause:
Even though your organization is not encrypted, it may be possible that someone on the team submitted a change with an encryption key because they have a local “cryptedservers.conf” file with a pair “server-key” entry for the cloud organization.
Answer:
Those changesets now have encrypted data, so they must be removed from the server. To do this, just right-click on the changeset and select Advanced>Delete changeset. Please note that a changeset can only be deleted if it has no other item related to it aside from its parent.
In order to prevent the issue from happening again, you need to remove any “cryptedservers.conf” files located under the client binaries folder or the user configuration files.
- Binaries in Windows: C:\Program Files\PlasticSCM5\client
- Local configuration in Windows: C:\Users\xxxxx\AppData\Local\plastic4