Symptoms:
During a checkin or pull operation you see an error with the following message: “The authentication or decryption has failed”.
Cause:
It is highly probable a member of the team has been working with an invalid encryption key. Data from that user is encrypted with a wrong encryption key and for the rest of the team those assets cannot be decrypted.
Resolution:
Identify the user with the wrong encryption key. You can review the latest changesets created and use the diff changeset operation (double click on a changeset) to check if you can review the content. If it fails, get the changeset owner to close the GUI, stop the local Plastic SCM server (if there is one) and remove the following files:
- C:\Program Files\PlasticSCM5\server\cryptedservers.conf
- C:\Users\<user_name>\AppData\Local\plastic4\cryptedservers.conf
- All the key files referenced inside the “cryptedservers.conf” files.
Then, start the local Plastic SCM Server, open the GUI and ask the developer to submit again the changes.
If you are still having issues, please contact the support team for help.