Symptoms:
- I want to know which methods of payment are accepted.
- I’m interested in paying in my local currency.
- I want to change my billing information.
- I need a copy of my invoice.
Cause:
You’re interested in using OneSignal for customer messaging and want to understand more about the pricing, billing options, and plan structure.
Resolution:
How can I pay?
We accept online payments through Visa, MasterCard, American Express, Discover, Diners Club International, JCB, and PayPal.
Billing is handled securely by Recurly with 128-bit SSL encryption. We don't save any of your billing information on our site.
If you are interested in an Enterprise Plan, you also have the option to invoice payments.
Can I pay in my local currency?
At this time, OneSignal only accepts payments in USD. When making payments, please ensure that all invoices are paid in USD.
How do I find or download an invoice?
Growth & Pro Plans: From your dashboard, click on the Organizations Tab. Click on the name of your organization from the list, then click on the Billing tab to see a list of your invoices.
Enterprise Plans: Please send a request to ar@onesignal.com with your full Business Name. We will follow up shortly.
How can I be added or removed from the billing contact list?
To be added or removed from the billing contact list, send an email request to ar@onesignal.com Please cc’ the account owner so we can verify this.
How do I change my credit card information?
You can edit your billing details using the custom billing details link that was sent to you in your Billing Welcome Email that you received when you first activated your payment account. If you cannot locate your link, you can request it by sending an email to ar@onesignal.com
My payment was declined. Now what?
If your credit card failed, please make sure to update it. Our payment gateway will automatically attempt to recharge your account in the next batch.
Can I delete subscribers to decrease my bill?
Yes, and you should delete users as close to the start of the billing cycle as possible to not be charged for them. If you send messages to all devices for the cycle, then delete users midway or at the end of the cycle, you will still be charged based on your fair usage for that cycle.
Please follow the Delete Users Guide for steps on how to do this.
More Information:
What is the pricing model?
Where can I purchase OneSignal?
How can I cancel or downgrade?
How do I contact OneSignal?
Comments
2 comments
Good
Contact me if you work
Please sign in to leave a comment.