Symptoms:
- I want to understand which plan makes the most sense for my company.
- I want to know the difference in features and pricing between the different plan types.
- I want to understand how much I will be billed each month.
- I’m not sure how subscribers are billed.
Cause:
You’re interested in using OneSignal for customer messaging and want to understand more about the pricing and plan structure.
Resolution:
We offer four different plans:

Each company has unique needs. While many users decide on a plan based on feature requirements, these are the general guidelines we had in mind:
Free Plan: Designed for companies with basic messaging needs or companies that want to try out OneSignal first before choosing a paid plan.
Growth Plan: Designed for companies that are starting to level up their messaging capabilities.
Professional Plan: Designed for companies that have more complex targeting and segmentation needs.
Enterprise Plan: Designed for companies with sophisticated messaging needs or companies that would like an annual contract.
Please see our pricing page for a more detailed breakdown of each plan’s features.
How do you charge?
OneSignal’s paid plans have a fixed platform fee and variable usage fee.
For mobile push and web push notifications, we charge based on subscribers, and you get an unlimited volume of sends. For In-App Messages, we charge based on impressions, since messages can be delivered to all app users regardless of whether they have subscribed. Using the purple slides on our pricing page, you can estimate what your monthly cost would be based on the number of subscribers and in-app message impressions you are anticipating.
The Growth Plan and the Professional Plan are month-to-month and you can upgrade, downgrade or cancel at any time. The Enterprise Plan is on an annual contract and can be customized with volume-based pricing.
What is a subscriber?
A subscriber is a device that has opted-in to push notifications. Subscribers are defined as unique device and app combinations, so the same device opted into two different apps would count as two subscribers for your organization.
Unsubscribed devices do not factor into your subscriber counts.
What is an impression?
An impression is an In-App Message that is shown on a device. Impressions are defined as each message served, so sending the same recurring IAM would count as separate impressions each time a user views it.
More Information:
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