Symptoms:
- I have not used Unity before and would like to know how to activate my license.
- I want to activate a Personal, Plus, Pro, or Enterprise license but the system is not letting me do it.
- My project is not launching.
- I see an error during the online activation process.
Cause:
If you are not able to activate your Unity license online, the system won't let you open the Editor.
The online activation process can be interrupted by using a closed network or by having a weak/ intermittent internet connection, for example. This can cause errors during the activation process.
Resolution:
If you cannot activate your Unity license online, or you receive errors during the regular activation process, the usual workaround is to activate offline (manual activation).
Manual activation steps for Unity Hub 3.0+
- Open the Unity Hub.
- Click the account icon in the top left of the window to log in to your Unity ID.
- Click Preferences (cog icon) in the top left of the window.
- Click Licenses to the left of the window.
- Click the blue Add button.
- Click Activate with license request.
- Select the Create license request option and save the file in the location you desire.
- Click on the link to the manual activation page.
- On the Manual activation page, click Browse and select the license request file from the location you saved it in step 7 > click Next.
- Select whether you have a Unity Plus or Pro or Unity Personal Edition license.
- If using a Unity Plus or Pro license, enter your serial number and click Next.
- If using Unity Personal Edition, select which option applies to you and click Next.
- Click Download license file and save the .ulf file on your machine.
- Open the Hub, proceed to the Activate with license file section in the How to activate an existing license window and then load the license file (.ulf) from the location you saved this in the previous step by clicking on the folder icon.
- Select the .ulf license file and click Open or Select file.
- Click Activate to load the license file.
Your Unity license is now activated.
More Information:
If you encounter any problems, please reach out to Customer Service detailing the steps taken, including screenshots of any errors you encountered if possible.
If you receive the error 'Your serial number is not valid' you may need to return a previous activation. See the article 'How do I return the activations on my Pro/ Plus/ Enterprise license?'
Related Articles:
Comments
10 comments
That didn't help, the unity hub problem says that there's a problem activating a new personal license. Yes: I am logged. Yes, I have internet conection. Yes, I refreshed
Help. Unity Hub problem activation license/
Hello emanuel guilherme and OOOO,
Thank you both for your comments. I am sorry to hear you are both experiencing some problems activating your license with the Hub.
The comments section is not the best place to try and solve these issues, so I will create a ticket for each of you and reach out to you shortly via email.
If there is anything else you need in the meantime, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
I've tried this and i got this error; "Unable to save license". Cant figure it out
the same problem, unable to save license
Exactly :(
Hello. this guide is for older versions of unity hub. i cant see the MANUAL ACTIVATION option in the license management section...
Same here
yup same
Hello all,
I am sorry to hear that you are all experiencing some issues activating in the Unity Hub. This is certainly not the experience that we would wish any of our users to have.
In order to help you get this resolved, I would advise emailing us directly at support@unity3d.com or alternatively, you can submit a ticket via this web form.
These kinds of things are solved much easier via email where we can offer detailed troubleshooting advice.
We look forward to hearing from you soon to get this resolved!
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