Symptoms:
- My Humble Bundle assets are missing.
- Some of my Humble Bundle assets are missing.
- I redeemed my Humble Bundle voucher, but I only see some of my assets.
Cause:
When Humble Bundle assets are redeemed, entitlement isn't given automatically. Once the asset seat is assigned, the assets will appear in the user's My Assets section in the Asset Store.
Due to a time-out issue, some Humble Bundle assets are being added to accounts a few hours after vouchers have been redeemed successfully.
Resolution:
Once the assets have been added to your account, you will need to assign the seat to yourself within the Asset Management section of your Unity account.
To assign Humble Bundle assets to yourself, follow the below steps:
- Sign in at id.unity.com
- Click Organizations to the left of the screen.
- Click Manage (cog icon) to the right of the Organization you redeemed your vouchers on.
- Click Asset Management to the left of the screen.
- Hover the cursor under the Assigned to/ Shared with section next to the asset you want to assign > Click Manage Seats (person icon).
- Click the box to the right of the user(s) you want to give access to.
- Click the blue Assign Seat(s) button.
The selected assets now appear under your My Assets section in the Asset Store.
Please note: If your assets are not appearing under the Asset Management section of your Unity ID page within 48 hours after redeeming, contact Customer Service.
More Information:
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Comments
7 comments
Thank you very much. This was specific, concise and exactly what I needed.
Thank you very much.
Mine are still not showing up
Thank you, my assets are now displayed. It would be good to have bulk action for assigning seats to multiple entries at the same time as it reduces the clicking time.
Hello there,
Thank you both for your recent comments.
charlesgood21 I am sorry to hear that your assets were not showing for you. I have just double-checked your account today and I can see the assets are now showing, so you should be able to follow the steps above with no other issues.
Thank you so much for your feedback Katrin Nitsche. We always value our user's feedback, both positive and negative, so I will make sure that your voice is heard and pass those comments along, so we can look to update our interface.
Thank you again!
I am trying to redeem my recent humble bundle assets purchase, but after entering the code I only get a delay followed by an error 502 bad gateway on what should be the "review" page.
I hope I didn't just waste $50 on 2 bundles!!
Hi Eric Ameres
Thanks for contacting us.
I can see that the Customer Service team is handling your case under ticket number #1112378. Please, feel free to reply to the ticket.
All the best.
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