Symptoms:
- I cannot open any of my projects.
- I cannot create any new projects.
- I have activated my license, but the Hub still tells me I need to activate a license. Why?
- I see the error, "No valid Unity Editor license found. Please activate your license!”, but I have an active license. What should I do?
- My license isn't showing in the Hub.
Cause:
There is a known bug with the Hub version 3.1.1, causing the activation file to be corrupt. If you face this issue, please submit a bug report and then continue with the workaround below.
Resolution:
The workaround for this bug is to activate manually using the command line method.
The workaround differs depending on your machine. Click the below links to jump to the solution for your operating system (OS):
Important: If you see the error, 'Your serial number is not valid' when attempting to activate your Unity license, please see the article, 'I see the error 'Your serial number is not valid’ when attempting to activate through the Unity Hub. What does this mean?' for your resolution. |
Comments
4 comments
unity.exe -batchmode -createManualActivationFile -logfile does not seem to be working...
I ran that in cmd next to the exe... it seems to be doing something, but then nothing happens... no error message, no nothing...
The log file got generated in "AppData\Roaming\UnityHub\logs\info-log.json" but no .alf file anywhere to be found...
EDIT : seems like it was something on Unity's side, My old 2018 license is back and everything is working again...
The linked website for manual activation, https://license.unity3d.com/manual , is constantly refreshing on me, making it impossible to upload my ALF file. As of this morning I am unable to work. Unity Hub 3.1.1 was working for me on Friday without issue. I have not updated Hub or my project since then.
Everybody in my office is running into the same issue. Please advise.
EDIT: As of a minute ago, it is now working. My guess was a pretty significant Unity license server issue that incorrectly assumed that licenses were invalid.
I have to manually renew/activate my Personal Edition license at https://license.unity3d.com/manual.
The page keeps on refreshing. So i cannot start any new project.
Hi Doker,
Thanks for reaching out.
For more investigation, I created ticket #1300804 for you. Please check about it.I hope we can get in touch soon. Thank you.
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