症状:
- 教育機関向けライセンスはどのようにアクティベートするのですか?
- 一括でアクティベーションできる方法はありますか?
- 複数のマシンで教育機関向けライセンスをアクティベートする必要があります。
原因:
教育機関向けライセンスをお持ちの方は、教室、又は施設にあるすべてのマシンをアクティベートする必要があります。しかしながら、一度にすべてのマシンをアクティベートできる方法はまだありません。ただしバッチファイルによるアクティベーションをサポートしており、簡単に実施いただけます。
解決策:
複数のマシンを一括でアクティベートする公式な方法はまだありません。しかし、コマンドラインを使用した方法があります。
コマンドライン経由でのアクティベーション:
Windows: C:\Program Files\Unity\Editor\Unity.exe" -batchmode -username name@example.edu.uk -password XXXXXXXXXXXXX -serial E3-XXXX-XXXX-XXXX-XXXX-XXXX –quit
Mac: Applications/Unity/Unity.app/Contents/MacOS/Unity- quit -batchmode -serial
E3-XXXX-XXXX-XXXX-XXXX-XXXX -username name@example.edu.uk -password
XXXXXXXXXXXXX
施設ごとにシステムは異なるように設定されているため、正確なコマンドを提供することはできませんが、いくつかの典型的なコマンドを提供することはできます。
コマンドラインの全リストは Unity Manual page を参照ください。
コマンドラインでアクティベートしてもうまくいかない場合は、ネットワーク環境が原因の可能性があります。
プロキシ・ファイアウォールを設置している場合、弊社サーバーへの接続をブロックしてしまいますので、80 と 443 のポートの許可をお願いします。
又、以下のホスト名を追加してください:
(IP's may vary):
id.unity.com
api.unity.com
license.unity3d.com
activation.unity3d.com
core.cloud.unity3d.com
sl-http.unity3d.com
developer.cloud.unity3d.com
accounts.unity3d.com
上記以外にも、以下のIPに(Googleが)コンタクトしているとの報告がございます:
74.125.226.222
173.194.43.30
プロキシを確認する:
HTTPS_proxy=https://proxyusername:proxypassword@proxyaddress.com:8080
UNITY_PROXYSERVER=https://proxyusername:proxypassword@proxyaddress.com:8080
その他の要因:
1) ネットワーク環境 - 教育機関の大半は機関専用のネットワーク網があり、インターネットにアクセスできない場合があります(コマンドラインで https://core.cloud.unity3d.com/api/login、ping を実行できるか確認できます)。
2) CACerts.pem に原因があるかどうかを確認するには、次のコードに従ってください:
CACerts.pem はレポジトリに含まれております。
3) 管理者以外のアカウントからアクティベートできる場合、そのマシン上のすべての非管理者アカウントでアクティベートが機能いたします。
4) 非管理者アカウントでアクティベートできない場合、管理者のマシンでアクティベートした後にライセンスファイルを特定し、そのマシンの共有フォルダに保存します。そうすることによって、別のユーザーがマシンにサインインしても、ライセンスファイルは共有されます。
ライセンスファイル (.ULF) は以下の場所で特定できます:
- Windows: C:\ProgramData\Unity
(ファイルが非表示になっている場合は、View をクリックし、Hidden Items のチェックボックスにチェックを入れる必要があります。)
- Mac: Library/Application Support/Unity
ネットワーク環境設定を変更してもアクティベーションが実行されない場合は、手動でライセンスをアクティベーションすることで解決できます。オフライン(手動)アクティベーションのガイダンスは、Unity Manual に記載されています。
注:Unityは、各キャンパスのファイアウォール、IPなどが大きく異なる可能性があるため、教育環境内でのアクティベーションプロセスに関する提案のみしかできません。
.ULF ファイルを学生様がアクセスできる共有ネットワークエリアに移動してください。ファイルが管理者エリアにある場合、学生様のログインは機能しません。
Unity のインストールを実行するために、一般的な管理者メールアドレスとパスワードのログインを作成することをお勧めします。これを行うと、学生様は必要なときにログインできるようになります。