この記事は、以下に該当するお客様向けのご案内です。
- アセットをインポートすると、‘’Failed To Import Package: Could Not Decompress Package’’ エラーが発生する。
原因:
使用しているマシンのディスク容量、ディレクトリ名、権限など様々な原因が考えられます。
解決策:
ターゲットディスクにパッケージを解凍するための十分な容量があるか確認してください。
ターゲットディスクの空き容量を増やしてみてください。問題なく操作を行うためには、アセットのパッケージの2倍以上の空き容量が必要となります。
ご利用の Unity プロジェクトまたは Unity パッケージが、日本語など非ラテン文字が含まれるディレクトリに存在していないか確認してください。
そのディレクトリ内の日本語や非ラテン文字を削除してください。
Unity パッケージ、その親ディレクトリ、Unity プロジェクトのディレクトリに読み / 書き込み権限があるか確認してください。
これらのディレクトリへの読み取り / 書き込み権限を与えてください。
ダウンロードしたパッケージが壊れていないか確認してください。
ダウンロードの際にパッケージが壊れてしまうことがあります。ご利用のコンピュータに 7zip がインストールされている場合、Unity のアセットのパッケージを開いてテストすることができます。パッケージは以下のパスに保存されています。
Windows: C:\Users\ユーザー名\AppData\Roaming\Unity\Asset Store-5.x Mac: /Users/ユーザ名/Library/Unity/Asset Store-5.x Linux: ~/.local/share/unity3d/Asset Store
7zip でパッケージを開いたときにエラーが表示されたり、空のパッケージが表示されたりする場合は、パッケージが壊れている可能性があります。一度パッケージを削除して、アセットストアから再ダウンロードをお試しください。この問題は高頻度で報告されており、再ダウンロードすることで解決する場合が多くあります。
また、ウィルスチェックソフトの検疫機能が原因でパッケージが壊れることがあります。再度ダウンロードしてもアセットのパッケージが破損する場合は、ウィルスチェックソフトの機能を一時的に停止してダウンロードをお試しください。
参考情報:
ご質問やエラーは、Unity Community に投稿することもできます。Unity のコミュニティは200万人以上のユーザーを持っており、その多くがこのような問題を解決するためにフォーラムやアンサーのページを毎日利用しています。
また、以下のフォーラムは上記のエラーを解決するご参考になるかもしれません。
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