증상:
- 이전에 에셋을 구매 했습니다.
- 에셋을 다운로드 받고 싶지만, 에셋 스토어에서 더 이상 판매 하지 않습니다.
- 구매한 에셋을 찾을 수 없습니다.
원인:
퍼블리셔가 사용할 수 있는 지원 중단 (Deprecate) 기능이 있습니다. 퍼블리셔가 에셋의 지원 중단 조치를 진행하여 에셋을 에셋 스토어에서 삭제한 경우, 기존에 에셋을 구매한 사용자는 계속 해당 에셋에 액세스 할 수 있습니다. 다만, 에셋이 비활성화(Disabled) 된 경우에는 해당 에셋에 추가적으로 액세스 하실 수 없습니다.
또한, 퍼블리셔에 의해 에셋 스토어에 업로드 된 에셋이 특정 에셋의 저작권을 침해한 것으로 간주 되는 경우 에셋 스토어 상에서 해당 에셋이 삭제될 수 있습니다. 이 경우에도, 해당 에셋에 더 이상 액세스 하실 수 없습니다.
해결법:
이전에 에셋을 다운로드 한 경우:
이전에 에셋을 다운로드 한 적이 있는 경우, 해당 에셋이 기기의 로컬 파일 폴더에 있을 수 있습니다. 다음의 경로에서 에셋 파일을 확인하여 주시기 바랍니다:
- Windows: C:\Users\[UserName]\AppData\Roaming\Unity\Asset Store-5.x\[PublisherName]
- Mac: /Users/[UserName]/Library/Unity/Asset Store-5.x/[PublisherName]
.unitypackage 를 찾으셨다면, 해당 폴더를 드래그 앤 드롭(Drag and drop) 하여 프로젝트로 불러 올 수 있습니다. 또한 에디터의 프로젝트 윈도우에서 마우스 오른쪽 버튼을 클릭 한 후, Import Package > Custom package 를 클릭 한 후, 파일 탐색기를 이용하여 불러올 에셋을 선택 하실 수 있습니다.
이전에 다운로드 하지 않았으며, 에셋이 지원 중단 된 경우:
퍼블리셔가 에셋의 지원을 중단 한 경우, 이전에 에셋을 구입한 사용자에 한하여 에셋 다운로드가 가능합니다. 구매한 계정으로 로그인 한 경우, 에셋 스토어의 '내 에셋' 섹션에서 다운로드 할 수 있습니다.
다운로드가 되지 않을 경우, 인보이스 번호와 함께 고객 경험 팀으로 연락 주시면 확인을 도와 드리겠습니다.
이전에 다운로드 하지 않았으며, 에셋이 비활성 된 경우:
에셋이 비활성화(Disabled) 된 경우, 더 이상 해당 에셋을 이용하실 수 없습니다. 해당 내용에 대해 보다 자세한 안내를 받고자 하시는 경우, 고객 경험 팀으로 연락 주시면 확인을 도와 드리겠습니다.
참고자료: