증상:
- Unity Pro 무료 체험 라이선스를 활성화한 후 프로젝트에 워터마크가 표시됩니다.
- Unity Pro 라이선스에서 체험판 워터마크를 제거하고 싶습니다.
- Unity Pro 무료 체험판을 유료 라이선스로 업그레이드했지만 워터마크가 계속 표시됩니다.
- Unity Pro 유료 라이선스를 결제했지만 체험판 워터마크가 여전히 화면에 표시됩니다.
원인:
Unity Pro 무료 체험 라이선스를 이용하고 계시는 경우 기본적으로 빌드에 워터마크가 표시됩니다.
유료 Unity Pro 라이선스를 구매하여 이용하시는 경우, 해당 워터마크를 제거하실 수 있습니다. 통상적으로, 유료 Pro 라이선스를 구매하여 이용하고 계심에도 불구하고 빌드상에 체험판 워터마크가 표시되는 경우, 이는 특정 버전의 Unity 에디터에서 발생하는 버그입니다.
해결법:
상기 오류가 발생하는 경우, Unity 에디터에서 라이선스 정보의 업데이트를 진행하여 주셔야 합니다. 라이선스 정보 업데이트를 위하여 아래의 절차에 따라 업데이트를 진행하여 주시기 바랍니다:
- Unity 에디터를 실행하여 주시기 바랍니다.
- 상단 메뉴 표시줄에서 'Help' 버튼을 클릭합니다.
- 'Manage License' 버튼을 클릭합니다.
- 라이선스 관리와 관련 된 메뉴 창 중, 'Refresh' 버튼을 클릭합니다.
- 라이선스가 업데이트된 후 평가판 워터마크가 제거됩니다.
추가 문제 해결 방안:
상기 절차를 진행하신 후에도 평가판 워터마크가 여전히 표시되는 경우 아래와 같은 문제 해결 절차를 진행하여 주시기 바랍니다:
1. 아래의 웹사이트에 접속하여 최신 버전의 Unity 에디터를 사용하고 있는지 확인합니다.
https://unity.com/releases/editor/archive.
2. 만료된 .ULF 파일 삭제
간혹 라이선스를 활성화하는 동안 이전 라이선스 파일이 제대로 제거되지 않는 경우가 있습니다. 이러한 이전 라이선스 파일은 새 라이선스 파일의 생성을 차단할 수 있습니다. 해당 문제를 해결하기 위하여 아래의 문제 해결 단계를 진행하여 주시기 바랍니다:
- 작업 관리자를 사용하여 모든 Hub 프로세스를 닫습니다.
- 파일 브라우저를 사용하여 다음 위치로 이동합니다:
- Windows: C:ProgramData/Unity
- Mac: Library/Application Support/Unity - 해당 폴더에 포함된 .ULF 파일을 삭제합니다.
'라이선스는 어떻게 활성화하나요?' 문서에 설명된 단계에 따라 라이선스의 활성화 절차를 다시 진행하여 주시기 바랍니다.
3. Unity Hub 및 에디터 재설치
위의 문제 해결 단계를 수행하신 후에도 문제가 해결되지 않는 경우, 컴퓨터에서 Unity와 관련된 모든 항목을 완전히 제거하고 컴퓨터를 재시작한 다음 소프트웨어를 다시 설치해야 합니다.
이전 Unity 설치와 관련된 모든 파일을 제거하기 위해서는 C:ProgramData/Unity 및 C://Documents and Settings/All Users/Application Data/Pace Anti-Piracy/License 폴더와 해당 폴더에 포함된 모든 파일을 삭제하여 주시기 바랍니다.
혹 상기 모든 절차를 시도하여 보신 후에도 지속적으로 문제를 겪으시는 경우 Hub 로그 파일을첨부하시어 고객 경험 팀에 문의하여 주시기 바랍니다.
댓글
댓글 0개
이 문서에는 댓글을 달 수 없습니다.