Unity Build Automation build failures can occur if the local Unity version isn't yet available on the service, as new Editor versions require testing. The "Always Use Latest" option might not work immediately. To fix this, disable "Auto detect Unity version" and manually select one, or enable "Build with closest version" (with some restrictions). New versions usually appear within a few days of release.
Symptoms
- My builds are failing due to the local Unity version not being available on the Build Automation builders.
- I want to use the latest version of Unity, but I do not see it available in Unity Build Automation.
Cause
When new versions of the Unity Editor are released, they must first undergo testing in Unity Build Automation before being made available on the service. Thus, even if the 'Always Use Latest 20XX.X' option is selected, the version set locally in the project might not be available.
Resolution
In the Basic settings for your target, you can turn off the 'Auto detect Unity version' option and manually select the version from the Unity version dropdown. Alternatively, you can turn on the 'Build with closest version' setting.
Please keep in mind that the 'Build with closest version' setting is disabled for projects using manual Git (SSH), encrypted UVC projects, or if no source control provider has been specified.
Generally, the latest version of the Editor takes no more than a few days from release to be made available on the service.
More Information
Build target configurations (creating a build target)