症状:
- Unity Hub から Unity エディターをダウンロードしたいのですが、エラーが出てできません。
- 「インストールは失敗しました: Validation Failed」のエラーが発生します。
- 「ダウンロードに失敗しました: Validation Failed」のエラーが表示されます。
- エディターのダウンロードが止まったままで完了しません。
原因:
"インストールは失敗しました: Validation Failed" というエラーは、詳細を確認するためにログを参照するよう指示するメッセージです。Unity エディターのダウンロード中にエラーが発生する理由はいくつかあります:
- システム要件:デバイス(PC、Mac 等)が Unity エディターと Hub の最低システム要件を満たしていない可能性があります。
- ハードウェア制限:Unity エディターを外付けハードドライブや、クラウド、非ローカルストレージにインストールするとエラーが発生することがあります。
- パーミッション(権限):Unity Hub にエディターをインストールする権限がない場合があります。
- ネットワーク関連:WiFi 接続が不安定であったり、データ制限があるとダウンロードが途中で止まる場合があります。
- ウイルス対策ソフト、プロキシ:ウイルス対策ソフト、プロキシがダウンロードまたはインストールをブロックする場合があります。
- デバイスの設定:パス環境変数が正しく設定されていない、またはファイルパスに英文以外の文字が含まれていると、ダウンロードおよびインストールが完了しないことがあります。
解決策:
原因によって解決策は異なります。Unity をダウンロードする際に遭遇するエラーを解決するために、以下のステップを確認してください:
注意:大半のダウンロードエラーは、デバイスやネットワーク設定に起因しているため、一般的な解決策のみ提供できます。 |
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システム要件:ご自身のデバイスが Unity エディターと Hub の最低システム要件を満たしていることを確認してください。全てのシステム要件は Unity manual で確認できます。
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ハードウェア制限:インストールが継続的に失敗する場合、インストール場所を外部ドライブではなくローカルドライブに設定してみてください。Unity Hub を起動 > 環境設定 > インストール > インストール場所。
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パーミッション(権限):Unity Hub がデバイスに変更を加えることを許可していない場合、インストールは完了しません。ショートカットまたは実行ファイルを右クリックし、「管理者として実行」を選択して Unity Hub を管理者権限で実行してください。
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ネットワーク関連:
- 直接イーサネット接続を利用する: WiFi が弱い場合、有線のイーサネット接続を使用すると助けになります。
- データ制限を解除する: Windowsでデータ制限を設定している場合、設定 > ネットワークとインターネット > イーサネットに移動してデータ制限を削除します。
- VPN をオフ: プロキシサービスをオフにし、インターネット接続が安定して強力であることを確認します。
- ファイアウォール設定の見直し: ファイアウォール設定でポート 80 および 443 を許可して、Unity Hub がサーバーに接続できるようにします。
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スピードテスト: Speed Test などのツールを使用してネット速度をテストし、インターネットサービスプロバイダ(ISP)やネットワーク管理者と相談して弱いまたは断続的な接続の問題を解決します。
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ウイルス対策ソフト、プロキシ:全てのセキュリティ機能を一時的にオフにします。あるいは、以下のドメインをウイルス対策ソフトまたはプロキシの例外リストに追加してください:
- unity.com
- unity3d.com
- plasticscm.com
- google.com
- googleapis.com
- microsoft.com
- aka.ms
注: Defining exceptions on your web proxy の公開ガイドをご覧ください。
追加のステップ:
上記の対策が失敗した場合、Unity Hub を使用せずに Unity download archive から直接 Unity をダウンロードしてみてください。追加モジュールは選択せず、ダウンロードの競合を避けるために後で追加してください。
また、コマンドライン引数を使用してエディターとモジュールをダウンロードおよびインストールすることもできます(Using the Unity Hub from the command line)。
すべてが失敗した場合、Unity のクリーンインストールを試みてください。
その他:
全て行っても解決しない場合は、ログファイルを添えてカスタマーエクスペリエンスまでお問合せください。