症状:
- Unity Industry ライセンスを所有していますが、Unity Hub に Unity Pro と表示されています。
- Unity Hub には Unity Pro と Unity Industry ライセンスの両方が表示されます。
- Unity Hub に Pro と Enterprise の両方のライセンスが表示されるのはなぜですか。
原因:
Unity Industry や Unity Enterprise ライセンスはシリアルキーを使用せずにアクティベートできますが、シリアルキーは存在しています。Unity Industry や Unity Enterprise ライセンスは Named User Licensing (NUL)を使用しており、サインインするとライセンスが自動的にアクティベートされます。
ライセンスキーを使用してライセンスをアクティベートする場合(キーを手動で入力する場合)、.ULF(Unityライセンスファイル)が生成されます。これらは通常、Unity Proライセンスで使用されますが、2019 LTSより前のバージョンの Unity エディタを使用している場合は、Unity Industry や Unity Enterprise ライセンスのお客様も使用できます。2019 LTSより前のバージョンでは NUL がサポートされていないため、この使用事例ではライセンスキーを使用してアクティベートするのが適切となります。
NUL ライセンスファイルは.XML形式で保存され、以前手動でアクティベートされたライセンスは.ULF形式で表示されます。両方が存在する場合、Unity Hub には2つの異なるライセンスタイプが表示されます。
この表示は混乱を招くかもしれませんが、適切なライセンスを持っている限り、コンプライアンスやライセンスの条件には影響を与えません。また、実際の機能やライセンスの使用には影響がないため、安心して利用を続けることができます。
解決策:
.ULF アクティベーションをコンピューター上に残しておく必要がない場合(例えば、2019 LTSより前のバージョンの Editor を使用していない場合など)は、以下の手順に従って.ULFを削除することができます。
- タスクマネージャーまたは同様の機能から、Hub と Unity を完全に終了します。
-
C:\ProgramData\Unity
に移動し、そこに格納されている .ULF を削除します。 - Hub を再起動し、ログインします。
その他の情報: