This article explains how to cancel auto-renewal for Unity Academy/On-Demand training subscriptions, which have a 12-month commitment and auto-renew unless canceled. Users must sign in to their Unity ID, select their organization, manage the subscription, and choose to cancel auto-renewal. Access continues until the current billing period ends.
Symptoms:
- You no longer wish to continue your Unity Academy/On-Demand training subscription.
- You want to stop automatic billing for the Unity Academy (On-Demand training) service.
- You need to end your access to the Unity Academy training materials.
Cause:
Unity Academy subscriptions have a 12-month commitment. Please note the subscription renews for a new 12-month period unless auto-renewal is canceled.
Resolution:
To cancel auto-renewal.
- Sign in to your Unity ID.
- Select Organizations to the left of the screen
- Select the organization you used to subscribe to Unity Academy/On-Demand Training.
- Click Manage (cog icon) to the right of the subscription you wish to cancel in the Subscriptions section.
- Select the Manage subscription tab and scroll down the page.
- Click I want to cancel auto-renewal.
Please note:
- Your subscription will remain active until the end of the current billing period.
- You will continue to have access to the training materials until the subscription expires.
More information:
To learn more about canceling Unity subscriptions, please see the article, 'How do I cancel my subscription?'