Issue:
- The microphone remains active when Vivox is muted/set to not transmit.
Environment:
This can be seen most clearly on mobile devices where there is a visible indicator of the microphone being active, but it is also the case for other environments even without the indicator.
Cause:
To improve muting/unmuting speed, Vivox keeps the microphone active whenever the local participant is in a channel and the capture device is a valid capture device. Please note, the captured audio is discarded locally after capture rather than being transmitted.
Resolution:
- To disable the microphone, which will remove the OS microphone indicator, the capture device must be set to "No Device".
- To restore microphone functionality, the capture device should be set back to its previous device value.
For more information, please see the following documentation links: