Symptoms:
- Player conversation is heard normally during gameplay, but voice chat does not appear in captured game footage or game play recordings.
Cause:
This is most likely intended behavior by the platform, and beyond the control of Vivox. Many platforms—such as Xbox, PlayStation, and Meta Quest—classify voice chat as user generated content that may contain personally identifiable information or other potentially sensitive data. Because of this, a user’s rendered voice in game-chat is often excluded by default from any clips or gameplay recordings created using the platform's built-in recording tools.
The Vivox library follows platform guidelines to accurately categorize all of its audio streams as "player voice" where necessary, after which it's up to the individual platforms how they treat that type of audio.
Resolution:
Some platforms offer configuration options within their recording or user privacy settings that allow a user's mic audio to be included in recordings made by themselves or others in public games. In such cases, ensuring that player voice is included in gameplay recordings captured directly on the platform may require enabling specific settings individually on each device where you want the audio to be recorded.
Refer to your platform's official development documentation or public user setting guides for more information on how voice chat is handled in recordings.