Symptoms:
- Player conversation is heard normally during gameplay, but voice chat does not appear in captured game footage or game play recordings.
Special Note on Meta Quest: Vivox is aware of a change in behaviour starting in 2025 where remote participant voice no longer shows up in recordings made on Meta Quest, even when settings are configured to include it. Local voice is still captured. After an extensive investigation, it has been concluded that there is not a Vivox-implementation side solution to resolve this at the present time. We know this can be frustrating, and we hope full recording ability can be restored in the future for titles utilizing Vivox. Workaround on Meta Quest: Meta Quest 3 and Meta Quest 2 feature a 3.5mm audio port on the left side, allowing an external headset, earbuds, or headphones to be plugged in. Inserting an external audio device into this port allows remote participants' voice to show up in recordings like before. The latest Meta Quest 3S lacks a 3.5mm audio port. It has not been tested whether using an adapter to connect an external audio device to the 3S works around this issue. |
Cause:
This is most likely intended behavior by the platform, and beyond the control of Vivox. Many platforms—such as Xbox, PlayStation, and Meta Quest—classify voice chat as user generated content that may contain personally identifiable information or other potentially sensitive data. Because of this, a user’s rendered voice in game-chat is often excluded by default from any clips or gameplay recordings created using the platform's built-in recording tools.
The Vivox library follows platform guidelines to accurately categorize all of its audio streams as "player voice" where necessary, after which it's up to the individual platforms how they treat that type of audio.
Resolution:
Some platforms offer configuration options within their recording or user privacy settings that allow a user's mic audio to be included in recordings made by themselves or others in public games. In such cases, ensuring that player voice is included in gameplay recordings captured directly on the platform may require enabling specific settings individually on each device where you want the audio to be recorded.
Refer to your platform's official development documentation or public user setting guides for more information on how voice chat is handled in recordings.