Symptoms:
- I have received an email telling me that my Student plan is about to expire.
- I want to renew my Unity Student plan.
- I followed the steps in the email I received to renew my Student plan, but nothing happened. Why is this?
Cause:
Unity Student plans are valid for one year, after which you need to renew your Student plan to continue taking advantage of the benefits included.
Resolution:
Important: You can only renew once your current license has expired. It is ideal to allow at least 24 hours from the existing subscription expiring before re-submitting your application. |
You can renew your Unity Student plan after one year if you are still a student and your academic email address is still active in the school system.
When the plan expires, return to the Unity Student page and reverify your student status with SheerID to renew your license.
When submitting your renewal, we encourage you to confirm the submission is from the same account you used when you initially applied. Student verification can only be associated with one Unity ID.
More Information:
Before 31 Aug 2021, verification of student status was processed through GitHub. If you want to renew a plan you verified via GitHub, please reapply via the Unity Student page, following the instructions to reverify with SheerID.
Comments
9 comments
This process didn't work for me, just says 'Congratulations ...wait for an email'.
I had better luck with the following:
Assigning the seat triggers the email to come through.
You can try to "download serial keys" but the excel document contained no key in my case.
Hello Peter,
Thank you for your comment.
I am sorry to hear that you had some issues renewing your Student Plan.
After you have applied to renew your Student Plan, your renewal will be processed and an email will be sent to you to confirm that it has been setup. Once it has been renewed, you will need to assign yourself a Seat and reactivate your license using the serial key in the email, as you did originally.
The reason for this is that the Student Plan works a little differently to our other subscriptions, so the renewal process is not automatic. I hope this has helped.
If there is anything else you need in the meantime, please feel free to email us at support@unity3d.com or alternatively, you can submit a ticket via this web form.
Thanks Jarvis! That makes total sense.
It may be helpful to add that extra 'seat step' to the guide.
Same thing here - I have been getting the email reminders daily, I go through the process as well and the extension is only done 5 days at a time no new license code in the mail.
Hi Sean Batson
Thanks for contacting us.
Sorry for the inconvenience with your license for the Student Plan.
Since you have followed the process stated by Jarvis without any luck, I would recommend to send an email to Support at support@unity3d.com or alternatively, you can submit a ticket via this web form.
Someone from the Customer Service team will take a look at your issue.
Hello dear support team,
unfortunately I have a problem with the reactivation of my student plan.
I have gone through the process again as you described and so far everything has worked. But now when I try to activate the license key in Unity HUB, I always get the message: invalid Key.
I would be very happy about the solution of this problem.
Best regards
Thorsten
Hello Thorsten.
Derek from Unity Customer Service here.Thanks for reaching out to us.
I'm sorry to hear you're having trouble activating. I'll do my best to assist you.
I've had a look over your license in our system and can see that you've hit the activation limit.
Sometimes, when an OS does an automated update, it can change the machine ID. This can cause Unity to think you're activating on a new machine.
You can return the activations in within your Unity ID by following the instructions outlined here.
Once you have cleared the activations please try again, I believe this will narrow down the error.
If this does not work, sometimes a corrupted license file can get in the way of activating. If none of the above works. I recommend trying to delete your license file and trying again.
You may need to clear your existing Licensing files. These can cause the Editor to hang upon Reactivation.
Give the steps below a try, and let me know how you get on! The files may be hidden.
Delete this file:
* WinXP/Vista: C:/Documents and Settings/All Users/Application Data/Pace Anti-Piracy/License Files
* Win7: C:/ProgramData/PACE Anti-Piracy/License Files
* Mac: HD/Library/Application Support/PACE Anti-Piracy/License Files
and
* Windows: C:ProgramData/Unity
* Mac: Library/Application Support/Unity
Restart
Download Unity again from our website, since your original install might be corrupt.
Reinstall and test.
Secondly, if this doesn't not work, I would like to ask you to check your network. Unity requires an uninterrupted connection to activate, this means that a poor internet connection, firewall or proxy can get in the way of activating.
Is there any way you could temporarily disable any firewall or proxy you may have running whilst you activate?
If you can not shut these down, I recommend checking the link below to learn how to allow Unity through your network.
https://docs.unity3d.com/Manual/upm-network.html
Please feel free to get back to me if you have any follow up questions. All the best.
This process didn't work for me, The website did not ask me to re verify my student identity, and just says 'Congratulations ...wait for an email'. It seems that I received a reminder email from renew, but the website does not know that I want renew. I don't know what to do now. My account will expire in a month
Hello Gehan,
Thank you for your recent comment. I am sorry to hear that you are having some issues with renewing your Student Plan.
In order to get this resolved it would be best if you emailed us directly at support@unity3d.com or alternatively, you can submit a ticket via this web form and a member of our team will reach out to you as soon as they can.
We hope to hear from you soon. Have a nice day!
Please sign in to leave a comment.