Symptoms:
- I want to change my subscription payment date
- I want to customise the billing date for my Unity Pro / Unity Industry / Unity Enterprise
- Is it possible to adjust the billing date for my subscription?
- Can I make payment for my subscription on the first day or last day of the month instead?
Cause:
You have purchased a 12-month Unity Pro, Industry or Enterprise subscription via our Online Store with a monthly or yearly payment plan and wants to manage your payments by scheduling them on specific day of the month.
Resolution:
Unfortunately, the billing date of Unity subscriptions cannot be customised as it is automatically set based on the date the first purchase was made. The same date will be used for recurring payments each month or each year, depending on the payment plan you selected.
For example:
- You purchased Unity Pro subscription on 20 March 2025 with a monthly payment plan, your subsequent payment dates will be on 20th of every month until the end of your 12-month commitment.
In any case where it is necessary to change the billing date, you may consider a workaround by starting a new subscription on your preferred date. You may do so by selecting the 'Immediate Renewal' option on your subscription page, which will renew your subscription immediately based on the date you take this action. For more information, please refer to the article here.
Important: Selecting 'Immediate Renewal' will result in an immediate charge, and you will be entered into a new 12-month contract starting from the date of the renewal. |
If you require clarification or assistance, please contact the Customer Experience Team for further support.