Symptoms:
- I have purchased a Pixyz subscription but don’t know where to start.
- I am trying to activate my Pixyz license but I have a problem installing the software
- I am trying to activate my Pixyz license but the software returns an error message.
- I am trying to activate my Pixyz license but the software crashes on start-up.
- I am trying to activate my Pixyz license, but I see the error message, An error occurred while installing the license, Could not install the license on the computer, or Could not open the key.
Cause:
A Pixyz license activation failure can happen if you are trying to install your license on:
- A virtual environment.
- A remote machine.
- A machine connected with a VPN.
- A session without Admin rights.
- A weak or intermittent internet connection.
Resolution:
In order to activate a Pixyz license online, you must have a strong and stable internet connection to reach the license servers. Using a VPN, proxy, or even some antivirus software can interrupt this connection and cause the license activation to fail.
To ensure this is not what is causing your license activation to fail, disable any VPN or proxy you have running, and try switching off your antivirus/firewall for the activation process.
If you’re not able to disable your proxy or firewall, try the offline activation process.
Another cause for the activation process to fail is not having the correct permissions on your machine. This can prevent the software from accessing the correct place on your machine to save the license file (.lic). To launch the software with the correct administrative permissions, follow the below steps:
- Close the software from the task manager.
- Right-click the software icon on your desktop (Pixyz or the Unity Hub).
- Click Run as Administrator.
- Try activating your license again, following the steps in the article, ‘Online Mode’.
Important: The Pixyz licensing system is not designed to work with virtual or remote machines. Any attempt to activate on either one may result in an error.
More Information:
If you are still having trouble activating your license or launching Pixyz after following the above troubleshooting steps, please contact Customer Experience, and include:
- All the log files found in the following directory:
C:/Users/<username>/AppData/Roaming/<productname>/
- An offline activation code (found in the offline license manager panel)
- The .lic file at:
C:/ProgramData/<productname>/licenses
if it exists