Symptoms:
- When seen, Vivox status code
10012with no status message typically occurs during the connector_create or sign-in process, but it could also occur during other actions.
Cause:
(10012) errors are usually caused by network issues that prevent the connection from finalizing as connected or disconnected during a preset period.
Resolution:
To troubleshoot this error, check the device's or the local network's network configuration (for example, proxy or firewall restrictions). This issue is often seen in environments or countries with national firewalls or locations with slow internet connectivity.
Other causes of this error are beyond the developer's control. The best recourse is to implement retry logic that waits for a certain amount of time and then tries again. Configure this retry logic to give up or wave off after a few failures.
More information: