Symptoms:
-
In Unity and Unreal: The Vivox SDK status code
VxNetworkHttpInvalidCertificate (10077)
can occur when failing to successfully sign in a local user. -
In Vivox Core: The Vivox SDK status code
VxNetworkHttpInvalidCertificate (10077)
can occur in avx_resp_connector_create
response message when failing to successfully connect to the Vivox server with avx_req_connector_create
request.
Cause:
The Vivox SDK status code 10077 ("HTTP Invalid Certificate") has several possible causes:
- Incorrect date/time set on the device: this can cause a valid SSL certificate to appear expired.
- Poor network conditions or CPU contention during the SSL/TLS certification validation step of the sign in process.
- A local firewall or private network configuration intercepting and blocking certain SSL/TLS connections.
- Similar to firewall configurations, third-party anti-cheat software has occasionally intercepted and blocked parts of the Vivox sign in process after falsely flagging the network activity as unusual.
- SSL Certificates on the Vivox Server side are expired (this should not happen).
Resolution:
To troubleshoot this error, perform the following steps.
- Ensure that your device's system clock is set to the correct date and time.
- Close unnecessary apps to free up device resources. Try connecting to a different network or wait a little while and retry. Experiencing device/network lag or packet loss during sign in can sometimes result in this error.
- If you're connecting from a controlled private network, such as at a university or company office, please note that Vivox can send XMPP rather than typical HTTP over the 'web' traffic TCP/443 connection: any corporate firewall which is intercepting SSL/TLS and inspecting packets to enforce the content of those connections needs to make an exception.
Please see the following support article for more details: Vivox: What IPs and ports are required for Vivox to work? - Ensure any third-party anti-cheat software is up to date. In past cases where anti-cheat software has mistakenly blocked Vivox sign in activity, this issue with their software has typically been corrected in a patch to the anti-cheat library soon after.
- If disabling your anti-cheat software fixes the issue, please contact Vivox Support to report the 10077, and include the name and version of the anti-cheat software causing the issue.
- If you still encounter 10077 when signing into Vivox, check the Unity Service live status indicator for your assigned Vivox domain at status.unity.com to see if there are any current or recent outage incidents.
After following the above steps, if the issue occurs consistently and you do not see any current or recent service incident reported, contact Vivox Support to report the 10077 error. Please include the Vivox Server URL and Vivox Domain you are trying to connect to.