Symptoms:
The Vivox SDK status code VxErrorInvalidArgument (1008)
can occur in response to most SDK calls or requests where one or more arguments are provided.
NOTE: Older SDKs may see the status code 5008 instead of 1008.
Cause:
"Invalid Argument" errors almost always indicate a coding error in the Vivox implementation. The following list details a few of most common reasons to see VxErrorInvalidArgument
:
- Use of unsupported characters in usernames or channel names.
- Exceeding the max character limit in a username, channel name, or display name.
- Setting a volume value outside of the supported range.
- (In Vivox Core) Issuing a vx_request which leaves a required field empty.
Resolution:
Argument restrictions like supported characters or value ranges can vary based on the request and the specific Vivox SDK being used. Be sure to consult the appropriate developer documentation and API technical reference pages for information on valid input and required versus optional arguments for different types of SDK requests: