Symptoms:
The Vivox SDK status code VxSSLNegotiationToXmppServerFailed (5046)
can occur when failing to successfully sign in a local user.
Cause:
There are a several possible causes for a VxSSLNegotiationToXmppServerFailed (5046)
error:
- Incorrect date/time set on the device: this can cause a valid SSL certificate to appear expired.
- Poor network conditions or CPU contention during the SSL negotiation step of the sign in process.
- A local firewall or private network configuration intercepting and blocking certain SSL/TLS connections.
- SSL Certificates on the Vivox Server side are expired (this should not happen).
Resolution:
To troubleshoot this error, perform the following steps.
- Ensure that your device's system clock is set to the correct date and time.
- Close unnecessary apps to free up device resources. Try connecting to a different network or wait a little while and retry. Experiencing device/network lag or packet loss during sign in can sometimes result in this error.
- If you're connecting from a controlled private network, such as at a university or company office, please note that Vivox can send XMPP rather than typical HTTP over the 'web' traffic TCP/443 connection: any corporate firewall which is intercepting SSL/TLS and inspecting packets to enforce the content of those connections needs to make an exception.
Please see the following support article for more details: Vivox: What IPs and ports are required for Vivox to work? - If you still encounter 5046 when signing into Vivox, check the Unity Service live status indicator for your assigned Vivox domain at status.unity.com to see if there are any current or recent outage incidents.
After following the above steps, if the issue occurs consistently and you do not see any current or recent service incident reported, contact Vivox Support to report the 5046 error. Please include the Vivox Server URL and Vivox Domain you are trying to connect to.