Symptoms:
- Local user is unable to be heard by others when speaking in voice chat on iOS, even though they have a valid microphone selected, are unmuted, are set to transmit into the channel, are not blocked, et cetera.
Cause:
When using Vivox on iOS, before you can use audio, you must correctly initialize the AVAudioSession
category and options.
Resolution:
For information on how to configure the AVAudioSession
category correctly, refer to the support article appropriate to your Vivox SDK Version as linked below:
For versions matching or later than Vivox Unity 15.1.160000-pre.1, Unreal 5.16.0.unr.0, and Core 5.15.4:
For versions prior to (and not including) Vivox Unity 15.1.160000-pre.1, Unreal 5.16.0.unr.0, and Core 5.15.4: