Symptoms:
The local user is connected to a Vivox channel with other participants, but cannot hear others speaking.
Cause:
There are many potential causes for not being able to hear other channel participants, including on both the sending side (remote participant) and receiving side (local participant).
Resolution:
Below are several troubleshooting tips relevant to any Vivox SDK type and target platform. Note that the specific request/method used to perform the suggested actions varies by SDK type. Find the appropriate documentation for your Vivox SDK here: Where can I find Vivox SDK Documentation?
To help troubleshoot not being able to hear others in channel:
- Ensure your application has microphone permissions from each player who wishes to speak in voice chat.
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Note: on certain platforms, not having microphone permissions can cause a Vivox channel join request to fail if the following advice is not followed. If the player wishes to listen in to voice but not provide mic permissions, be sure to set the Vivox audio input device to the null device (
"No Device") before connecting to the channel.
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Note: on certain platforms, not having microphone permissions can cause a Vivox channel join request to fail if the following advice is not followed. If the player wishes to listen in to voice but not provide mic permissions, be sure to set the Vivox audio input device to the null device (
- Ensure each participant who wishes to speak or hear has joined the channel with audio capability, rather than as text-only.
- When connected to a Positional channel, participants will not be able to speak or hear in the channel until their player position has been set at least once. This is because Vivox needs to know who is around them in the 3D space before sending or receiving audio.
- For the speaking player: ensure they are transmitting audio into all channels, or into the specific channel they wish to be heard. Ensure the Vivox audio input device is unmuted and set appropriately.
- For the receiving player: ensure they have not mistakenly muted the channel or participant in the channel they wish to hear from. Ensure the Vivox audio output device is unmuted and set appropriately.