증상:
- 프로젝트에서 버그를 발견했습니다.
- UI에서 버그를 발견했습니다.
- Unity Hub 사용에 문제가 있습니다.
원인:
Unity가 예상대로 작동하지 않거나 오류 메시지가 출력되는 경우는 Unity Hub 또는 Unity 에디터에 기술적인 문제나 버그가 발생한 것이 원인일 수 있습니다. 아래와 비슷한 문제가 이미 확인되었을 수도 있습니다.
충돌이 발생해 Unity가 종료되고, 에디터나 프로젝트가 다시 열리지 않습니다.
콘솔 창에 에러가 표시됩니다.
Unity Hub에 문제가 발생해 라이선스, 프로젝트, 에디터 버전 관리가 불가능합니다.
해결법:
먼저 Unity 포럼 페이지와 답변 페이지를 둘러보는 것이 좋습니다. 사용자 커뮤니티에서 동일한 문제를 이미 해결하고 관련 정보를 공유했을 수도 있습니다.
해결책을 찾지 못한 경우에는 버그 리포트를 제출해야 합니다. Unity Hub에 문제가 발생했으면 Unity Hub를 통해 버그 리포트를 제출해야 합니다. 그 외 다른 버그는 에디터 내에서 리포트를 제출하세요.
에디터에서 버그 리포트를 제출하는 방법은 다음과 같습니다.
- Help를 클릭하고 드롭다운 메뉴에서 Report a bug를 선택합니다.
- 드롭다운 메뉴에서 무엇과 관련된 문제인지, 얼마나 자주 발생하는지를 선택합니다.
- 유효한 이메일 주소를 입력하고 제목과 설명 필드를 작성합니다.
- 마지막으로 Send를 누르면 버그 리포트가 제출됩니다.
Unity Hub에서 버그 리포트를 제출하는 방법은 다음과 같습니다.
- 모서리에서 이니셜이 표시된 계정 아이콘을 클릭한 다음, ‘버그 보고’를 선택합니다.
- 드롭다운 매뉴에서 이 현상이 얼마나 자주 발생하는지 선택하고, ‘What happened?’ 창에 어떤 문제인지 자세하게 적어 주세요.
- 목록에 있는 다른 필드를 모두 작성합니다. 그러지 않으면 버그 리포트가 전송되지 않습니다. ‘Issue Encountered’ 필드에는 문제를 간략하게 요약한 내용을 적습니다.
- ‘How can we reproduce that?’ 필드에는 사용 중인 Unity Hub의 버전과 문제를 재현하는 데 필요한 기타 세부 정보를 적습니다.
- 이메일 필드에는 유효한 이메일 주소를 입력합니다.
- 마지막으로 ‘Send’를 클릭하면 버그 리포트가 제출됩니다. 버그 리포트는 자동으로 Unity Hub 로그 파일에 포함됩니다.
버그가 제출되면 케이스 번호가 포함된 자동 확인 이메일이 전송됩니다. 이후 QA 팀에서 버그를 수정하기 적절한 팀에 할당합니다.
버그를 제출한 이후 2주 내에 답변을 받지 못했다면 사용자가 제출한 버그는 다음 릴리스에서 수정될 예정이거나, 다른 해결책이 있는 것입니다. 확인이 필요하다면 고객지원팀에 문의하세요.
추가 정보:
버그를 보고하는 방법에 대해 자세히 알아보려면 QA 페이지를 확인하세요.
기존 버그나 새로운 버그의 케이스 번호를 알고 있고, 그 버그들이 어떻게 처리되고 있는지 추적해 보려면 Issue Tracker 포털을 확인하세요.