Symptoms:
- I have signed up for a Unity Player account and have not received my verification code.
- I am not receiving a confirmation email after creating my Unity Player account.
Cause:
When signing up for your Unity Player account, a verification code is sent to the email address used to sign up. You need to enter the five-digit code within 30 minutes, or you will need to request a new code.
This is to finalize the account creation and ensure that access to the account is only made by the user and not by someone else.
Resolution:
First of all, please make sure that you check all email folders.
If you cannot locate your verification email in a secondary email inbox, please safelist all @unity3d.com emails within your email security settings. Strict filters can send these emails to your spam and junk mailboxes.
If you have not received your verification code after a minute, you can request a new code by selecting Resend a new code.
More information:
If you need help creating or verifying your account, please contact support at unity-player-login-support@unity3d.com