Symptoms:
- I have found a bug in the Editor, and I need to report it.
- I am experiencing a problem using the Hub and believe it may be a bug.
Cause:
If Unity is not working as you expect it to, or you see an error message, this may be due to a technical problem or a bug, either within the Unity Hub or the Editor.
You may have experienced an issue similar to those listed below:
- A project crash that has closed Unity prevents you from re-opening the Editor or your project.
- Errors are appearing in your console window.
- When using the Hub, there may be errors preventing you from managing your licenses, projects, or Editor versions.
Resolution:
It is always advised to first visit the Unity Discussions platform to search for your specific error or post about an issue to see if the community has experienced the same problem and solved it.
If the issue cannot be solved and and you have exhausted all other troubleshooting options, a bug report may need to be submitted.
Where the error is being shown will determine how this should be reported to Unity. For example, any errors seen within the Hub must be reported there. For any other bugs, please report them within the Editor itself.
Use the links below to jump to the solution for your version:
You can submit a bug report in the Editor by following the steps below:
- Click on Help, and from the drop-down menu, click Report a Bug.
- Complete the Title field summarising the issue.
- Specify the appropriate options from the drop-down menus What is the problem related to? and How often does it happen?
- The email address will be pre-populated if the Unity Hub is running. If the Hub is closed, an alternative email address can be entered. Select the option Share this bug report with someone else if there is another contact needed for updates.
- Complete the Details section, include steps to reproduce the issue and any other relevant information.
- Upload any additional attachments needed to support your bug report. (By default the project and log files will automatically be attached.)
- Finally, click Submit to submit the bug report.
You can submit a bug report in the Hub by following the steps below:
- Click on the account icon in the corner displaying your account initials. Select Help and support > Report a bug.
- Ensure that your Unity account email address is entered into the Email address field.
- Enter a brief summary of the bug into the Summary field.
- Enter a detailed description of the bug you are experiencing into the Description field.
- Explain the specific and exact steps taken to encounter the bug in the Steps to reproduce field.
- Click the Reproducibility drop-down and select the appropriate option.
- If there are any relevant files to support the bug, such as screenshots, attach them using the File attachments option.
- Finally, click Send report to submit the bug report. The bug report will automatically include your Hub log file.
You will receive an automatic confirmation email containing your case number when your bug is submitted. The QA team will then assign it to the right team to work on a fix.
If your bug does not get a response within two weeks, it may be that your specific bug is fixed in a later release or already has available workarounds. Please contact Unity Customer Experience for further assistance in this case.
More Information:
For more information on how to report bugs, visit Unity QA & Bug Reporting.
If you have a new or existing case number and wish to track its progress, check the Issue Tracker portal